[package] update aprx to 2.00 r421 (#7803)
authorFlorian Fainelli <florian@openwrt.org>
Sun, 22 Aug 2010 16:36:30 +0000 (16:36 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sun, 22 Aug 2010 16:36:30 +0000 (16:36 +0000)
SVN-Revision: 22761

net/aprx/Makefile
net/aprx/patches/100-Makefile_in.patch

index 6907fd787b96e29895814391f7255e776fa6e351..6a38e756a8d88f5fb39d6f227c6f147c0790a2de 100644 (file)
@@ -8,8 +8,8 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=aprx
-PKG_REV:=121
-PKG_VERSION:=0.99_r$(PKG_REV)
+PKG_REV:=421
+PKG_VERSION:=2.00_r$(PKG_REV)
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
@@ -35,7 +35,7 @@ endef
 CONFIGURE_ARGS += \
        --with-embedded \
 
-define Package/aprx/install    
+define Package/aprx/install
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_BIN) ./files/aprx.init $(1)/etc/init.d/aprx
        $(INSTALL_DIR) $(1)/etc
index d23f573482c2754f8ef21a0d350b29d6f1e1fc83..cb06f790cda1dca0f64ff3ea6395c7f18967e751 100644 (file)
@@ -1,18 +1,19 @@
-diff -ruN aprx-0.22.svn115.orig/Makefile.in aprx-0.22.svn115/Makefile.in
---- aprx-0.22.svn115.orig/Makefile.in  2008-07-06 17:28:27.000000000 -0400
-+++ aprx-0.22.svn115/Makefile.in       2008-07-06 17:29:42.000000000 -0400
-@@ -25,7 +25,8 @@
- CFLAGS=               @CFLAGS@ $(DEFS)
+diff -ruN aprx-2.00_r421.orig/Makefile.in aprx-2.00_r421/Makefile.in
+--- aprx-2.00_r421.orig/Makefile.in    2010-06-19 15:13:47.000000000 +0000
++++ aprx-2.00_r421/Makefile.in 2010-08-22 00:14:35.000000000 +0000
+@@ -27,8 +27,9 @@
+ CFLAGS=               @CFLAGS@
  
  # Linker and flags
 -LD=           @LD@
 +LD=           @CC@
- LDFLAGS=      @LDFLAGS@
+ LDFLAGS=      @LDFLAGS@ $(PROF)
 +datarootdir = @datarootdir@
  
  INSTALL=      $(srcdir)/install-sh
-@@ -75,10 +75,10 @@
- all:          $(PROGAPRX) $(PROGSTAT) man aprx.conf
+ INSTALL_PROGRAM=$(INSTALL)  -m 755
+@@ -89,10 +90,10 @@
  
  $(PROGAPRX):  $(OBJSAPRX) VERSION Makefile
 -              $(LD) $(LDFLAGS) -o $@ $(OBJSAPRX) $(LIBS)