backports: remove alx extra patch
authorLuis R. Rodriguez <mcgrof@do-not-panic.com>
Wed, 26 Jun 2013 19:32:33 +0000 (12:32 -0700)
committerLuis R. Rodriguez <mcgrof@do-not-panic.com>
Wed, 26 Jun 2013 19:32:33 +0000 (12:32 -0700)
The alx driver was upstreamed by Johannes, so this is
no longer required. Note that this driver is now GPLv2
or later, BSD folks will have to look at the old unified
tree for a permissive licensed port.

Signed-off-by: Luis R. Rodriguez <mcgrof@do-not-panic.com>
patches/collateral-evolutions/network/0001-netdev_ops/mwifiex.patch
patches/collateral-evolutions/network/62-usb_driver_lpm/drivers_net_wireless_rtlwifi_rtl8192cu_sw.patch
patches/unified-drivers/network/0002-alx-make-kconfig/alx.patch [deleted file]

index 0567191cfc1637bd0ea4ca9eeef7a407bed90559..58a38ab266dc20abc7af0359de4d4411693b3a51 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/net/wireless/mwifiex/main.c
 +++ b/drivers/net/wireless/mwifiex/main.c
-@@ -750,7 +750,7 @@ static const struct net_device_ops mwifi
+@@ -749,7 +749,7 @@ static const struct net_device_ops mwifi
  void mwifiex_init_priv_params(struct mwifiex_private *priv,
                                                struct net_device *dev)
  {
index 28b217385df7f816ecf77d887ed12f63e614f816..23181a00959536fb28b1fcc39b75b3d6aac31431 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/net/wireless/rtlwifi/rtl8192cu/sw.c
 +++ b/drivers/net/wireless/rtlwifi/rtl8192cu/sw.c
-@@ -385,7 +385,9 @@ static struct usb_driver rtl8192cu_drive
+@@ -386,7 +386,9 @@ static struct usb_driver rtl8192cu_drive
  #ifdef CONFIG_AUTOSUSPEND
        .supports_autosuspend = 1,
  #endif
diff --git a/patches/unified-drivers/network/0002-alx-make-kconfig/alx.patch b/patches/unified-drivers/network/0002-alx-make-kconfig/alx.patch
deleted file mode 100644 (file)
index 465e499..0000000
+++ /dev/null
@@ -1,32 +0,0 @@
---- a/drivers/net/ethernet/atheros/Kconfig
-+++ b/drivers/net/ethernet/atheros/Kconfig
-@@ -67,4 +67,22 @@ config ATL1C
-         To compile this driver as a module, choose M here.  The module
-         will be called atl1c.
-+config ALX
-+      tristate "Qualcomm Atheros L1F Gigabit Ethernet support"
-+      depends on PCI
-+      select CRC32
-+      select NET_CORE
-+      select MII
-+      ---help---
-+        This driver supports the Qualcomm Atheros L1F ethernet adapter.
-+        This driver supports following chipsets:
-+
-+        1969:1091 - AR8161 Gigabit Ethernet
-+        1969:1090 - AR8162 Fast Ethernet
-+        1969:10A1 - AR8171 Gigabit Ethernet
-+        1969:10A0 - AR8172 Fast Ethernet
-+
-+        To compile this driver as a module, choose M here.  The module
-+        will be called alx.
-+
- endif # NET_VENDOR_ATHEROS
---- a/drivers/net/ethernet/atheros/Makefile
-+++ b/drivers/net/ethernet/atheros/Makefile
-@@ -6,3 +6,4 @@ obj-$(CONFIG_ATL1) += atlx/
- obj-$(CONFIG_ATL2) += atlx/
- obj-$(CONFIG_ATL1E) += atl1e/
- obj-$(CONFIG_ATL1C) += atl1c/
-+obj-$(CONFIG_ALX) += alx/