ipq40xx: add MikroTik hAP ac2 support
authorRobert Marko <robimarko@gmail.com>
Thu, 6 Aug 2020 10:42:34 +0000 (12:42 +0200)
committerAlexander Couzens <lynxis@fe80.eu>
Fri, 18 Sep 2020 23:33:06 +0000 (01:33 +0200)
This commit adds support for the MikroTik RouterBOARD RBD52G-5HacD2HnD-TC
(hAP ac²), a  indoor dual band, dual-radio 802.11ac
wireless AP with integrated omnidirectional antennae, USB port and  five
10/100/1000 Mbps Ethernet ports.

See https://mikrotik.com/product/hap_ac2 for more info.

Specifications:
 - SoC: Qualcomm Atheros IPQ4018
 - RAM: 128 MB
 - Storage: 16 MB NOR
 - Wireless:
   · Built-in IPQ4018 (SoC) 802.11b/g/n 2x2:2, 2.5 dBi antennae
   · Built-in IPQ4018 (SoC) 802.11a/n/ac 2x2:2, 2.5 dBi antennae
 - Ethernet: Built-in IPQ4018 (SoC, QCA8075) , 5x 1000/100/10 port, passive PoE in
- 1x USB Type A port

Installation:
Boot the initramfs image via TFTP and then flash the sysupgrade
image using "sysupgrade -n"

Signed-off-by: Robert Marko <robimarko@gmail.com>
package/firmware/ipq-wifi/Makefile
package/firmware/ipq-wifi/board-mikrotik_hap-ac2.qca4019 [new file with mode: 0644]
target/linux/ipq40xx/Makefile
target/linux/ipq40xx/base-files/etc/board.d/02_network
target/linux/ipq40xx/base-files/etc/hotplug.d/firmware/11-ath10k-caldata
target/linux/ipq40xx/base-files/lib/upgrade/platform.sh
target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4018-hap-ac2.dts [new file with mode: 0644]
target/linux/ipq40xx/image/Makefile
target/linux/ipq40xx/patches-5.4/901-arm-boot-add-dts-files.patch

index 387b23d5563fd7a276c8ce17ecb527da2ccc7787..4089b2071727c782a8e970b4145dd2bec120701d 100644 (file)
@@ -40,6 +40,7 @@ ALLWIFIBOARDS:= \
        ezviz_cs-w3-wd1200g-eup \
        glinet_gl-s1300 \
        linksys_ea8300 \
+  mikrotik_hap-ac2 \
        mobipromo_cm520-79f \
        qxwlan_e2600ac
 
@@ -117,6 +118,7 @@ $(eval $(call generate-ipq-wifi-package,engenius_emr3500,EnGenius EMR3500))
 $(eval $(call generate-ipq-wifi-package,ezviz_cs-w3-wd1200g-eup,EZVIZ CS-W3-WD1200G EUP))
 $(eval $(call generate-ipq-wifi-package,glinet_gl-s1300,GL.iNet GL-S1300))
 $(eval $(call generate-ipq-wifi-package,linksys_ea8300,Linksys EA8300))
+$(eval $(call generate-ipq-wifi-package,mikrotik_hap-ac2,Mikrotik hAP ac2))
 $(eval $(call generate-ipq-wifi-package,mobipromo_cm520-79f,MobiPromo CM520-79F))
 $(eval $(call generate-ipq-wifi-package,qxwlan_e2600ac,Qxwlan E2600AC))
 
diff --git a/package/firmware/ipq-wifi/board-mikrotik_hap-ac2.qca4019 b/package/firmware/ipq-wifi/board-mikrotik_hap-ac2.qca4019
new file mode 100644 (file)
index 0000000..b4dc6fa
Binary files /dev/null and b/package/firmware/ipq-wifi/board-mikrotik_hap-ac2.qca4019 differ
index 4d9b2debcaedf540fdac63d3062b0e8241f68adc..e3bf7e0dd6cd4d6db6cbcaeedc7a21a4c6332ca4 100644 (file)
@@ -3,7 +3,7 @@ include $(TOPDIR)/rules.mk
 ARCH:=arm
 BOARD:=ipq40xx
 BOARDNAME:=Qualcomm Atheros IPQ40XX
-FEATURES:=squashfs fpu ramdisk nand
+FEATURES:=squashfs fpu ramdisk nand minor
 CPU_TYPE:=cortex-a7
 CPU_SUBTYPE:=neon-vfpv4
 SUBTARGETS:=generic
index 2966fbf1fbae7605219274055ca27c2e62b049d0..9ca29d80716983fa06de09f07667a9c26e5b3c96 100755 (executable)
@@ -52,7 +52,8 @@ ipq40xx_setup_interfaces()
                ;;
        avm,fritzbox-4040|\
        linksys,ea6350v3|\
-       linksys,ea8300)
+       linksys,ea8300|\
+       mikrotik,hap-ac2)
                ucidef_set_interfaces_lan_wan "eth0" "eth1"
                ucidef_add_switch "switch0" \
                        "0u@eth0" "1:lan" "2:lan" "3:lan" "4:lan"
@@ -158,6 +159,11 @@ ipq40xx_setup_macs()
                wan_mac=$(mtd_get_mac_ascii devinfo hw_mac_addr)
                lan_mac=$(macaddr_add "$wan_mac" 1)
                ;;
+       mikrotik,hap-ac2)
+               wan_mac=$(cat /sys/firmware/mikrotik/hard_config/mac_base)
+               lan_mac=$(macaddr_add $wan_mac 1)
+               label_mac="$wan_mac"
+               ;;
        esac
 
        [ -n "$lan_mac" ] && ucidef_set_interface_macaddr "lan" $lan_mac
index d68e8d54b8ad3e8456a98808607a4bc21b4014bc..74aea555fdbd9196ef11cad06a2a6e36b03b11a4 100644 (file)
@@ -129,6 +129,9 @@ case "$FIRMWARE" in
                caldata_valid "202f" || caldata_extract "ART" 0x1000 0x2f20
                ath10k_patch_mac $(macaddr_add $(get_mac_binary "/sys/bus/i2c/devices/0-0050/eeprom" 0x66) +2)
                ;;
+       mikrotik,hap-ac2)
+               caldata_sysfsload_from_file "/sys/firmware/mikrotik/hard_config/wlan_data" 0x0 0x2f20
+               ;;
        netgear,ex6100v2 |\
        netgear,ex6150v2)
                caldata_extract "ART" 0x1000 0x2f20
@@ -224,6 +227,9 @@ case "$FIRMWARE" in
                caldata_valid "202f" || caldata_extract "ART" 0x5000 0x2f20
                ath10k_patch_mac $(macaddr_add $(get_mac_binary "/sys/bus/i2c/devices/0-0050/eeprom" 0x66) +3)
                ;;
+       mikrotik,hap-ac2)
+               caldata_sysfsload_from_file "/sys/firmware/mikrotik/hard_config/wlan_data" 0x8000 0x2f20
+               ;;
        netgear,ex6100v2 |\
        netgear,ex6150v2)
                caldata_extract "ART" 0x5000 0x2f20
index 0bae8e16817c45ecf992e9605f584842568f0d2f..b3c51d008960c5e93691264d132068d535b0b4eb 100644 (file)
@@ -121,3 +121,13 @@ platform_do_upgrade() {
                ;;
        esac
 }
+
+platform_pre_upgrade() {
+       local board=$(board_name)
+
+       case "$board" in
+       mikrotik,hap-ac2)
+               [ -z "$(rootfs_type)" ] && mtd erase firmware
+               ;;
+       esac
+}
diff --git a/target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4018-hap-ac2.dts b/target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4018-hap-ac2.dts
new file mode 100644 (file)
index 0000000..a1f113f
--- /dev/null
@@ -0,0 +1,240 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+/* Copyright (c) 2020, Robert Marko <robimarko@gmail.com> */
+
+#include "qcom-ipq4019.dtsi"
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+#include <dt-bindings/soc/qcom,tcsr.h>
+
+/ {
+       model = "Mikrotik hAP ac2";
+       compatible = "mikrotik,hap-ac2";
+
+       memory {
+               device_type = "memory";
+               reg = <0x80000000 0x08000000>;
+       };
+
+       chosen {
+               stdout-path = "serial0:115200n8";
+       };
+
+       aliases {
+               led-boot = &led_user;
+               led-failsafe = &led_user;
+               led-running = &led_user;
+               led-upgrade = &led_user;
+       };
+
+       soc {
+               rng@22000 {
+                       status = "okay";
+               };
+
+               mdio@90000 {
+                       status = "okay";
+               };
+
+               counter@4a1000 {
+                       compatible = "qcom,qca-gcnt";
+                       reg = <0x4a1000 0x4>;
+               };
+
+               tcsr@1949000 {
+                       compatible = "qcom,tcsr";
+                       reg = <0x1949000 0x100>;
+                       qcom,wifi_glb_cfg = <TCSR_WIFI_GLB_CFG>;
+               };
+
+               tcsr@194b000 {
+                       /* select hostmode */
+                       compatible = "qcom,tcsr";
+                       reg = <0x194b000 0x100>;
+                       qcom,usb-hsphy-mode-select = <TCSR_USB_HSPHY_HOST_MODE>;
+                       status = "okay";
+               };
+
+               ess_tcsr@1953000 {
+                       compatible = "qcom,tcsr";
+                       reg = <0x1953000 0x1000>;
+                       qcom,ess-interface-select = <TCSR_ESS_PSGMII>;
+               };
+
+               tcsr@1957000 {
+                       compatible = "qcom,tcsr";
+                       reg = <0x1957000 0x100>;
+                       qcom,wifi_noc_memtype_m0_m2 = <TCSR_WIFI_NOC_MEMTYPE_M0_M2>;
+               };
+
+               usb2: usb2@60f8800 {
+                       status = "okay";
+               };
+
+               usb3: usb3@8af8800 {
+                       status = "okay";
+               };
+
+               crypto@8e3a000 {
+                       status = "okay";
+               };
+
+               watchdog@b017000 {
+                       status = "okay";
+               };
+
+               ess-switch@c000000 {
+                       status= "okay";
+               };
+
+               edma@c080000 {
+                       status = "okay";
+               };
+       };
+
+       keys {
+               compatible = "gpio-keys";
+
+               reset {
+                       label = "reset";
+                       gpios = <&tlmm 63 GPIO_ACTIVE_LOW>;
+                       linux,code = <KEY_RESTART>;
+               };
+
+               mode {
+                       label = "mode";
+                       gpios = <&tlmm 5 GPIO_ACTIVE_LOW>;
+                       linux,code = <KEY_RFKILL>;
+               };
+       };
+
+       leds {
+               compatible = "gpio-leds";
+
+               power {
+                       label = "hap-ac2:green:power";
+                       gpios = <&tlmm 0 GPIO_ACTIVE_HIGH>;
+                       default-state = "keep";
+                       panic-indicator;
+               };
+
+               led_user: user {
+                       label = "hap-ac2:green:user";
+                       gpios = <&tlmm 3 GPIO_ACTIVE_HIGH>;
+               };
+       };
+};
+
+&tlmm {
+       serial_pins: serial_pinmux {
+               mux {
+                       pins = "gpio60", "gpio61";
+                       function = "blsp_uart0";
+                       bias-disable;
+               };
+       };
+
+       spi_0_pins: spi_0_pinmux {
+               pin {
+                       function = "blsp_spi0";
+                       pins = "gpio55", "gpio56", "gpio57";
+                       drive-strength = <2>;
+                       bias-disable;
+               };
+               pin_cs {
+                       function = "gpio";
+                       pins = "gpio54";
+                       drive-strength = <2>;
+                       bias-disable;
+                       output-high;
+               };
+       };
+
+       enable-usb-power {
+               gpio-hog;
+               gpios = <2 GPIO_ACTIVE_HIGH>;
+               output-high;
+               line-name = "enable USB power";
+       };
+};
+
+&blsp_dma {
+       status = "okay";
+};
+
+&blsp1_spi1 {
+       status = "okay";
+
+       pinctrl-0 = <&spi_0_pins>;
+       pinctrl-names = "default";
+       cs-gpios = <&tlmm 54 GPIO_ACTIVE_HIGH>;
+
+       flash@0 {
+               reg = <0>;
+               compatible = "jedec,spi-nor";
+               spi-max-frequency = <40000000>;
+
+               partitions {
+                       compatible = "mikrotik,routerboot-partitions";
+                       #address-cells = <1>;
+                       #size-cells = <1>;
+
+                       partition0@80000 {
+                               label = "RouterBoot";
+                               reg = <0x80000 0xe000>;
+                               read-only;
+                       };
+
+                       hard_config {
+                               read-only;
+                       };
+
+                       dtb_config {
+                               read-only;
+                       };
+
+                       soft_config {
+                       };
+
+                       partition4@1000000 {
+                               compatible = "mikrotik,minor";
+                               label = "firmware";
+                               reg = <0x100000 0xf00000>;
+                       };
+               };
+       };
+};
+
+&blsp1_uart1 {
+       status = "okay";
+
+       pinctrl-0 = <&serial_pins>;
+       pinctrl-names = "default";
+};
+
+&cryptobam {
+       status = "okay";
+};
+
+&usb3_hs_phy {
+       status = "okay";
+};
+
+&usb3_ss_phy {
+       status = "okay";
+};
+
+&usb2_hs_phy {
+       status = "okay";
+};
+
+&wifi0 {
+       status = "okay";
+
+       qcom,ath10k-calibration-variant = "Mikrotik-hAP-ac2";
+};
+
+&wifi1 {
+       status = "okay";
+
+       qcom,ath10k-calibration-variant = "Mikrotik-hAP-ac2";
+};
index ea0d733678ad7522c9c025f62fbdea02ea40ffda..efe6dccd01e648931a53f300a7da5dbabdef8d24 100644 (file)
@@ -569,6 +569,28 @@ define Device/meraki_mr33
 endef
 TARGET_DEVICES += meraki_mr33
 
+define Device/MikrotikNOR
+       $(call Device/FitImageLzma)
+       DEVICE_VENDOR := MikroTik
+       BLOCKSIZE := 64k
+       IMAGE_SIZE := 16128k
+       AUX_LOADER_UART := NONE
+       KERNEL_INITRAMFS_SUFFIX := -fit-uImage.elf
+       PLATFORM := mikrotik-ipq4xxx
+       KERNEL = kernel-bin | lzma | fit lzma $$(DTS_DIR)/$$(DEVICE_DTS).dtb | ipq-aux-loader-kernel elf
+       IMAGES = sysupgrade.bin
+       IMAGE/sysupgrade.bin := append-kernel | kernel2minor -s 1024 | pad-to $$$$(BLOCKSIZE) | \
+       append-rootfs | pad-rootfs | append-metadata | check-size $$$$(IMAGE_SIZE)
+endef
+
+define Device/mikrotik_hap-ac2
+       $(call Device/MikrotikNOR)
+       DEVICE_MODEL := hAP ac2
+       SOC := qcom-ipq4018
+       DEVICE_PACKAGES := ipq-wifi-mikrotik_hap-ac2 -kmod-ath10k-ct kmod-ath10k-ct-smallbuffers
+endef
+TARGET_DEVICES += mikrotik_hap-ac2
+
 define Device/mobipromo_cm520-79f
        $(call Device/FitzImage)
        $(call Device/UbiFit)
index e2dc45a39fac0bce7933618e8d1ec009928cc916..3d1c72514e8ba096cba767d5d11672858355a0ff 100644 (file)
@@ -12,7 +12,7 @@ Index: linux-5.4.63/arch/arm/boot/dts/Makefile
 ===================================================================
 --- linux-5.4.63.orig/arch/arm/boot/dts/Makefile
 +++ linux-5.4.63/arch/arm/boot/dts/Makefile
-@@ -837,11 +837,52 @@ dtb-$(CONFIG_ARCH_QCOM) += \
+@@ -837,11 +837,53 @@ dtb-$(CONFIG_ARCH_QCOM) += \
        qcom-apq8074-dragonboard.dtb \
        qcom-apq8084-ifc6540.dtb \
        qcom-apq8084-mtp.dtb \
@@ -29,6 +29,7 @@ Index: linux-5.4.63/arch/arm/boot/dts/Makefile
 +      qcom-ipq4018-ex6100v2.dtb \
 +      qcom-ipq4018-ex6150v2.dtb \
 +      qcom-ipq4018-fritzbox-4040.dtb \
++      qcom-ipq4018-hap-ac2.dts \
 +      qcom-ipq4018-jalapeno.dtb \
 +      qcom-ipq4018-meshpoint-one.dtb \
 +      qcom-ipq4018-nbg6617.dtb \