packages/rp-l2tp: use new service functions
authorNicolas Thill <nico@openwrt.org>
Sun, 13 Nov 2011 22:15:26 +0000 (22:15 +0000)
committerNicolas Thill <nico@openwrt.org>
Sun, 13 Nov 2011 22:15:26 +0000 (22:15 +0000)
SVN-Revision: 29049

net/rp-l2tp/Makefile
net/rp-l2tp/files/rp-l2tpd.init

index d120c342ab7bd3979c8d139175e0b39f242eea85..61e9cce3bf7d0807681f1d8ab3902e570cab1b5c 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2010 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=rp-l2tp
 PKG_VERSION:=0.4
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/rp-l2tp
index 4895e179438a83bbe92f4581c31e6bcd3fc3a4f1..cff1f15d2e4f348fe6580e05d813549dbb459093 100644 (file)
@@ -1,17 +1,13 @@
 #!/bin/sh /etc/rc.common
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 
 START=60
-DEFAULT=/etc/default/rp-l2tpd
-RUN_D=/var/run
-[ -f $DEFAULT ] && . $DEFAULT
 
 start() {
-       [ -d $RUN_D ] || mkdir -p $RUN_D
-       l2tpd $OPTIONS
+       service_start /usr/sbin/l2tpd
 }
 
 stop() {
-       killall l2tpd
+       service_stop /usr/sbin/l2tpd
 }