projects
/
openwrt
/
staging
/
lynxis.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
aec1b6b
)
build: avoid failing in append-metadata if image could not be generated
author
Felix Fietkau
<nbd@nbd.name>
Mon, 4 Dec 2017 19:24:24 +0000
(20:24 +0100)
committer
Felix Fietkau
<nbd@nbd.name>
Mon, 4 Dec 2017 19:24:51 +0000
(20:24 +0100)
The image build might have failed due to a size check
Signed-off-by: Felix Fietkau <nbd@nbd.name>
include/image-commands.mk
patch
|
blob
|
history
diff --git
a/include/image-commands.mk
b/include/image-commands.mk
index 1ec5252972c3a012c9bef782133fedb41af78b58..8db046bdea6a928be6152de5b69046b18a02711b 100644
(file)
--- a/
include/image-commands.mk
+++ b/
include/image-commands.mk
@@
-281,7
+281,7
@@
metadata_json = \
}'
define Build/append-metadata
- $(if $(SUPPORTED_DEVICES),echo $(call metadata_json,$(SUPPORTED_DEVICES)) | fwtool -I - $@)
+ $(if $(SUPPORTED_DEVICES),
-
echo $(call metadata_json,$(SUPPORTED_DEVICES)) | fwtool -I - $@)
endef
define Build/kernel2minor