[packages] openssh: Upgrade to 5.0p1
authorAndy Boyett <agb@openwrt.org>
Thu, 19 Jun 2008 04:28:09 +0000 (04:28 +0000)
committerAndy Boyett <agb@openwrt.org>
Thu, 19 Jun 2008 04:28:09 +0000 (04:28 +0000)
SVN-Revision: 11535

net/openssh/Makefile
net/openssh/patches/100-no_cast_fix.patch
net/openssh/patches/110-no_ripemd_fix.patch

index e70d006135e49a2ef821c7f0b997b529babec808..7d9b6d0d80edd95d4542c413d75d1313b17e3c85 100644 (file)
@@ -9,16 +9,16 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=openssh
-PKG_VERSION:=4.7p1
+PKG_VERSION:=5.0p1
 PKG_RELEASE:=1
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/ \
                ftp://openbsd.wiretapped.net/pub/OpenBSD/OpenSSH/portable/ \
-               ftp://ftp.belnet.be/packages/openbsd/OpenSSH/portable/ \
-               ftp://ftp.de.openbsd.org/pub/unix/OpenBSD/OpenSSH/portable/
-PKG_MD5SUM:=50a800fd2c6def9e9a53068837e87b91
+               ftp://ftp.belnet.be/packages/openbsd/OpenSSH/portable/ \
+               ftp://ftp.de.openbsd.org/pub/unix/OpenBSD/OpenSSH/portable/
+PKG_MD5SUM:=1f1dfaa775f33dd3328169de9bdc292a
 
 PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
index 50382bf8ff99f7b889b06c91cd2149654f5afee4..c0ed6c9c4b398db7ec65df2f32778ec835442cbf 100644 (file)
@@ -1,7 +1,5 @@
-Index: openssh-4.7p1/cipher.c
-===================================================================
---- openssh-4.7p1.orig/cipher.c        2007-10-02 16:53:04.000000000 -0500
-+++ openssh-4.7p1/cipher.c     2007-10-02 16:53:04.000000000 -0500
+--- a/cipher.c
++++ b/cipher.c
 @@ -72,7 +72,9 @@
  
        { "3des-cbc",           SSH_CIPHER_SSH2, 8, 24, 0, EVP_des_ede3_cbc },
index a76826e418108ed67355a2fef087858c1c722bf9..6276b0a5384092929bf30accdfbf0ea8d64b6bdd 100644 (file)
@@ -1,7 +1,5 @@
-Index: openssh-4.7p1/mac.c
-===================================================================
---- openssh-4.7p1.orig/mac.c   2007-10-02 16:53:04.000000000 -0500
-+++ openssh-4.7p1/mac.c        2007-10-02 16:53:04.000000000 -0500
+--- a/mac.c
++++ b/mac.c
 @@ -59,8 +59,10 @@
        { "hmac-sha1-96",               SSH_EVP, EVP_sha1, 96, -1, -1 },
        { "hmac-md5",                   SSH_EVP, EVP_md5, 0, -1, -1 },