projects
/
openwrt
/
staging
/
ynezz.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
4297f4f
)
ppp: use --gc-sections to save a tiny bit of space
author
Felix Fietkau
<nbd@nbd.name>
Tue, 13 Dec 2016 12:09:58 +0000
(13:09 +0100)
committer
Felix Fietkau
<nbd@nbd.name>
Wed, 14 Dec 2016 11:13:13 +0000
(12:13 +0100)
Signed-off-by: Felix Fietkau <nbd@nbd.name>
package/network/services/ppp/Makefile
patch
|
blob
|
history
diff --git
a/package/network/services/ppp/Makefile
b/package/network/services/ppp/Makefile
index 2b78761ea51e9556f7e9b660f96c59ec6519ac99..70af3a2df5ba8088def4e0255ec6f0e54a9deb51 100644
(file)
--- a/
package/network/services/ppp/Makefile
+++ b/
package/network/services/ppp/Makefile
@@
-172,6
+172,9
@@
$(call Build/Configure/Default,, \
$(PKG_BUILD_DIR)/pppd/plugins/pppoatm/linux/
endef
+TARGET_CFLAGS += -ffunction-sections -fdata-sections
+TARGET_LDFLAGS += -Wl,--gc-sections
+
MAKE_FLAGS += COPTS="$(TARGET_CFLAGS)" \
PRECOMPILED_FILTER=1 \
STAGING_DIR="$(STAGING_DIR)"