tools: add xxhash package for ccache
authorChukun Pan <amadeus@jmu.edu.cn>
Mon, 20 Jan 2025 15:10:36 +0000 (23:10 +0800)
committerChristian Marangi <ansuelsmth@gmail.com>
Thu, 6 Feb 2025 11:55:21 +0000 (12:55 +0100)
The ccache build requires xxhash, which is download from
the Internet. So add host-build package for xxhash.

Fixes: #16851
Signed-off-by: Chukun Pan <amadeus@jmu.edu.cn>
[ use git source proto ]
Link: https://github.com/openwrt/openwrt/pull/17700
Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
tools/Makefile
tools/xxhash/Makefile [new file with mode: 0644]

index b16c5d9c5b1e6c5e003f6dba86eabe77eed0e953..dd49ea5e1054414a315183c06a93be5a28ae30d4 100644 (file)
@@ -146,8 +146,9 @@ endif
 
 ifneq ($(CONFIG_CCACHE)$(CONFIG_SDK),)
 $(foreach tool, $(filter-out zstd zlib xz pkgconf patch ninja meson libressl expat cmake,$(tools-y)), $(eval $(curdir)/$(tool)/compile += $(curdir)/ccache/compile))
-tools-y += ccache
-$(curdir)/ccache/compile := $(curdir)/cmake/compile
+tools-y += ccache xxhash
+$(curdir)/xxhash/compile := $(curdir)/cmake/compile
+$(curdir)/ccache/compile := $(curdir)/xxhash/compile
 endif
 
 # in case there is no patch tool on the host we need to make patch tool a
diff --git a/tools/xxhash/Makefile b/tools/xxhash/Makefile
new file mode 100644 (file)
index 0000000..5d5754d
--- /dev/null
@@ -0,0 +1,25 @@
+# SPDX-License-Identifier: GPL-2.0-only
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=xxHash
+PKG_VERSION:=0.8.3
+
+PKG_SOURCE_PROTO:=git
+PKG_SOURCE_URL=https://github.com/Cyan4973/xxHash
+PKG_SOURCE_VERSION:=e626a72bc2321cd320e953a0ccf1584cad60f363
+PKG_MIRROR_HASH:=234cfc24004c1b97d3ec9c48e976347b31a513a68de40f57a765667eb89dbbb0
+
+PKG_LICENSE:=BSD-2-Clause
+PKG_LICENSE_FILES:=LICENSE
+
+include $(INCLUDE_DIR)/host-build.mk
+include $(INCLUDE_DIR)/cmake.mk
+
+CMAKE_C_COMPILER_LAUNCHER :=
+CMAKE_CXX_COMPILER_LAUNCHER :=
+
+CMAKE_BINARY_SUBDIR := build
+CMAKE_SOURCE_SUBDIR := cmake_unofficial
+
+$(eval $(call HostBuild))