projects
/
openwrt
/
staging
/
jow.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
5d3031c
)
Package support for IP over ATM
author
Florian Fainelli
<florian@openwrt.org>
Fri, 14 Sep 2007 08:18:46 +0000
(08:18 +0000)
committer
Florian Fainelli
<florian@openwrt.org>
Fri, 14 Sep 2007 08:18:46 +0000
(08:18 +0000)
SVN-Revision: 8775
package/kernel/modules/network.mk
patch
|
blob
|
history
diff --git
a/package/kernel/modules/network.mk
b/package/kernel/modules/network.mk
index d11a981354c2c0479cea3f1311fe524e7b2db8e2..d0147daface76a3749d015ed4420b50276e90083 100644
(file)
--- a/
package/kernel/modules/network.mk
+++ b/
package/kernel/modules/network.mk
@@
-293,6
+293,22
@@
endef
$(eval $(call KernelPackage,pppoa))
+define KernelPackage/ipoa
+ SUBMENU:=$(NSMENU)
+ TITLE:=IPoA support
+ DEPENDS:=kmod-atm
+ KCONFIG:=CONFIG_ATM_CLIP
+ FILES:=$(LINUX_DIR)/net/atm/clip.$(LINUX_KMOD_SUFFIX)
+ AUTOLOAD:=$(call AutoLoad,40,clip)
+endef
+
+define KernelPackage/ipoa/description
+ Kernel modules for IPoA (IP over ATM) support
+endef
+
+$(eval $(call KernelPackage,ipoa))
+
+
define KernelPackage/mppe
SUBMENU:=$(NSMENU)
TITLE:=Microsoft PPP compression/encryption