projects
/
openwrt
/
staging
/
lynxis.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
cf7199f
)
The attached patch replaces $(1) install by $(if $(1), $(1), install) in the definiti...
author
Travis Kemen
<thepeople@openwrt.org>
Fri, 5 Mar 2010 20:19:48 +0000
(20:19 +0000)
committer
Travis Kemen
<thepeople@openwrt.org>
Fri, 5 Mar 2010 20:19:48 +0000
(20:19 +0000)
Then its possible to do this in ncurses Makefile:
define Build/Install
$(call Build/Install/Default, install.libs install.data)
endef
This patch does not affect anything else, as if no parameter is given,
it will use install as before.
-Raphael
SVN-Revision: 19996
include/package-defaults.mk
patch
|
blob
|
history
diff --git
a/include/package-defaults.mk
b/include/package-defaults.mk
index 017a86d1e8d0d4309d10602093be10aa90b16d1e..ecc3af499fd27ce0a0c2533cba4003358eb65a91 100644
(file)
--- a/
include/package-defaults.mk
+++ b/
include/package-defaults.mk
@@
-122,7
+122,7
@@
define Build/Install/Default
$(MAKE_VARS) \
$(MAKE) -C $(PKG_BUILD_DIR)/$(MAKE_PATH) \
$(MAKE_INSTALL_FLAGS) \
- $(
1) install
;
+ $(
if $(1), $(1), install)
;
endef
define Build/Dist/Default