uboot-ath79: add new U-Boot package for Atheros/QCA devices
authorINAGAKI Hiroshi <musashino.open@gmail.com>
Fri, 26 Apr 2024 14:33:24 +0000 (23:33 +0900)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 28 Jul 2024 16:47:56 +0000 (18:47 +0200)
Add U-Boot package for the devices that based on Atheros/Qualcomm
Atheros SoCs.

Signed-off-by: INAGAKI Hiroshi <musashino.open@gmail.com>
Link: https://github.com/openwrt/openwrt/pull/15432
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
package/boot/uboot-ath79/Makefile [new file with mode: 0644]

diff --git a/package/boot/uboot-ath79/Makefile b/package/boot/uboot-ath79/Makefile
new file mode 100644 (file)
index 0000000..cd1fc16
--- /dev/null
@@ -0,0 +1,30 @@
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/kernel.mk
+
+PKG_VERSION:=2024.07
+PKG_HASH:=f591da9ab90ef3d6b3d173766d0ddff90c4ed7330680897486117df390d83c8f
+
+UBOOT_USE_INTREE_DTC:=1
+
+include $(INCLUDE_DIR)/u-boot.mk
+include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/host-build.mk
+
+define U-Boot/Default
+  BUILD_TARGET:=ath79
+  BUILD_SUBTARGET:=generic
+  UBOOT_IMAGE:=u-boot.bin
+  UBOOT_CONFIG:=ap121
+  HIDDEN:=1
+endef
+
+# don't stage files to bindir, let target/linux/ath79/image/*.mk do that
+define Package/u-boot/install
+endef
+
+define Build/InstallDev
+       $(INSTALL_DIR) $(STAGING_DIR_IMAGE)
+       $(INSTALL_DATA) $(PKG_BUILD_DIR)/$(UBOOT_IMAGE) $(STAGING_DIR_IMAGE)/$(BUILD_VARIANT)-$(UBOOT_IMAGE)
+endef
+
+$(eval $(call BuildPackage/U-Boot))