projects
/
openwrt
/
staging
/
kaloz.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
6acecfb
)
change the an openssl sed command to be safe for -Wl,-rpath-link in ldflags
author
Felix Fietkau
<nbd@openwrt.org>
Wed, 3 Sep 2008 13:19:41 +0000
(13:19 +0000)
committer
Felix Fietkau
<nbd@openwrt.org>
Wed, 3 Sep 2008 13:19:41 +0000
(13:19 +0000)
SVN-Revision: 12511
package/openssl/Makefile
patch
|
blob
|
history
diff --git
a/package/openssl/Makefile
b/package/openssl/Makefile
index f19551df3dfcada90cc9396e1e5ad6e14ef244e0..dce755053851db4f99d04383dba3b47e24380542 100644
(file)
--- a/
package/openssl/Makefile
+++ b/
package/openssl/Makefile
@@
-122,7
+122,7
@@
define Build/InstallDev
$(CP) $(PKG_INSTALL_DIR)/usr/lib/lib{crypto,ssl}.{a,so*} $(1)/usr/lib/
mkdir -p $(1)/usr/lib/pkgconfig
$(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/{openssl,libcrypto,libssl}.pc $(1)/usr/lib/pkgconfig/
- $(SED) 's
,$(TARGET_LDFLAGS),,
g' $(1)/usr/lib/pkgconfig/{openssl,libcrypto,libssl}.pc
+ $(SED) 's
#$(TARGET_LDFLAGS)##
g' $(1)/usr/lib/pkgconfig/{openssl,libcrypto,libssl}.pc
endef
define Package/libopenssl/install