projects
/
openwrt
/
staging
/
nbd.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
d3b4790
)
tools/ccache: always disable documentation compilation
author
Linhui Liu
<liulinhui36@gmail.com>
Wed, 22 Mar 2023 05:20:23 +0000
(13:20 +0800)
committer
Hauke Mehrtens
<hauke@hauke-m.de>
Sun, 2 Apr 2023 16:31:41 +0000
(18:31 +0200)
Speed up compilation.
Also remove useless include target.mk
(
b492e69bd2d09aaa2c3c76b52203cbb3527eb2f7
).
Signed-off-by: Linhui Liu <liulinhui36@gmail.com>
tools/ccache/Makefile
patch
|
blob
|
history
diff --git
a/tools/ccache/Makefile
b/tools/ccache/Makefile
index 6824dbddfd40a5cd8f3777e07c82c3d856ef3c57..9b5731d5b9f994dfb8515f16175f4e0d5983f539 100644
(file)
--- a/
tools/ccache/Makefile
+++ b/
tools/ccache/Makefile
@@
-5,7
+5,6
@@
# See /LICENSE for more information.
#
include $(TOPDIR)/rules.mk
-include $(INCLUDE_DIR)/target.mk
PKG_NAME:=ccache
PKG_VERSION:=4.7.4
@@
-22,10
+21,7
@@
CMAKE_HOST_OPTIONS += \
-DCMAKE_CXX_COMPILER_LAUNCHER="" \
-DCMAKE_SKIP_RPATH=FALSE \
-DCMAKE_INSTALL_RPATH="${STAGING_DIR_HOST}/lib" \
+ -DENABLE_DOCUMENTATION=OFF
-DREDIS_STORAGE_BACKEND=OFF
-ifneq (docs-$(CONFIG_BUILD_DOCUMENTATION),docs-y)
-CMAKE_HOST_OPTIONS += -DENABLE_DOCUMENTATION=OFF
-endif
-
$(eval $(call HostBuild))