ltq-vdsl-vr9-app: fix error handling during disconnection
authorJan Hoffmann <jan@3e8.eu>
Fri, 12 Jul 2024 13:49:49 +0000 (15:49 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Sat, 31 Aug 2024 17:40:21 +0000 (19:40 +0200)
Use the correct return value in error message.

Fixes: 1daaef31b352 ("ltq-vdsl-app: disconnect when service is stopped")
Signed-off-by: Jan Hoffmann <jan@3e8.eu>
package/network/config/ltq-vdsl-vr9-app/Makefile
package/network/config/ltq-vdsl-vr9-app/patches/200-autoboot.patch

index c51489e2c5fa33ca5e335033da35bbb3b2a08f34..e2042bf314d893b724504cbdad737ee5074933e0 100644 (file)
@@ -9,7 +9,7 @@ include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=ltq-vdsl-vr9-app
 PKG_VERSION:=4.17.18.6
-PKG_RELEASE:=5
+PKG_RELEASE:=6
 PKG_BASE_NAME:=dsl_cpe_control
 PKG_SOURCE:=$(PKG_BASE_NAME)_vrx-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@OPENWRT
index cc6feb94aa9f9abcb652b391c94131e3d80b9034..d949162f5877e2acb734f62c6c3f52769ac9aa72 100644 (file)
@@ -60,7 +60,7 @@ a state where an explicit start command is necessary to connect again.
 +      {
 +         DSL_CCA_DEBUG(DSL_CCA_DBG_ERR, (DSL_CPE_PREFIX
 +            "Autoboot configuration for device (%d) failed!, nRet = %d!"
-+            DSL_CPE_CRLF, nDevice, sAutobootCtl.accessCtl.nReturn));
++            DSL_CPE_CRLF, nDevice, sAutobootCfg.accessCtl.nReturn));
 +      }
 +
 +      memset(&sAutobootCtl, 0, sizeof(DSL_AutobootControl_t));