apk: host: set lua version to 5.1 to fix help
authorJonas Gorski <jonas.gorski@gmail.com>
Thu, 14 Nov 2024 10:21:41 +0000 (11:21 +0100)
committerJonas Gorski <jonas.gorski@gmail.com>
Thu, 14 Nov 2024 10:58:39 +0000 (11:58 +0100)
Commit b2a84c86e3 ("apk: host: make the help available") enabled the
host build for lua (5.1) as a dependency, but apk defaults to lua 5.3.
This caused it to ignore our lua, and only build the help if the host
system had lua 5.3 installed.

Fix this by explicitly setting the lua version to ours.

Fixes: b2a84c86e3 ("apk: host: make the help available")
Signed-off-by: Jonas Gorski <jonas.gorski@gmail.com>
package/system/apk/Makefile

index 2d637fa180987dfdc3e0ff786363a47f38ea44c8..fec6d5325c7e58766c84c45e5638daf775c56c96 100644 (file)
@@ -53,6 +53,7 @@ MESON_HOST_VARS+=VERSION=$(PKG_VERSION)
 MESON_VARS+=VERSION=$(PKG_VERSION)
 
 MESON_HOST_ARGS += \
+       -Dlua_version=5.1 \
        -Dcompressed-help=false \
        -Ddocs=disabled \
        -Durl_backend=wget \