qca-ssdk: fix compiling for ipq60xx
authorRobert Marko <robimarko@gmail.com>
Sun, 23 Jun 2024 15:24:57 +0000 (17:24 +0200)
committerRobert Marko <robimarko@gmail.com>
Sun, 23 Jun 2024 15:43:36 +0000 (17:43 +0200)
Trying to compile for ipq60xx will fail with:
ERROR: modpost: "qca808x_phy_reset" [build_dir/target-aarch64_cortex-a53_musl/linux-qualcommax_ipq60xx/qca-ssdk-2024.06.13~c451136b/qca-ssdk.ko] undefined!

So, lets fix this by disabling Manhattan switch and PHY support as this is
the new 2.5G quad port switch that is not present on ipq60xx boards.

Fixes: 87a45ea43207 ("kernel: qca-ssdk: update 12.5 to 2024-06-13")
Signed-off-by: Robert Marko <robimarko@gmail.com>
package/kernel/qca-ssdk/Makefile

index 9c5d4925b88e08f3a1eb28ac434f1715dadca59d..16b2b4477d9a04d5a5dc9ba4a4164fff00c6b93d 100644 (file)
@@ -47,8 +47,9 @@ MAKE_FLAGS+= \
        SoC=$(CONFIG_TARGET_SUBTARGET) \
        SHELL="$(BASH)" \
        PTP_FEATURE=disable SWCONFIG_FEATURE=disable \
-       ISISC_ENABLE=disable IN_QCA803X_PHY=FALSE \
-       IN_QCA808X_PHY=FALSE IN_MALIBU_PHY=FALSE \
+       ISISC_ENABLE=disable MHT_ENABLE=disable \
+       IN_QCA803X_PHY=FALSE IN_QCA808X_PHY=FALSE \
+       IN_MALIBU_PHY=FALSE \
        $(LNX_CONFIG_OPTS)
 
 ifeq ($(CONFIG_TARGET_SUBTARGET), "ipq807x")