projects
/
openwrt
/
staging
/
florian.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
bf58e39
)
build: allow val.% targets to bypass the prepare steps
author
Felix Fietkau
<nbd@nbd.name>
Fri, 5 May 2017 11:12:23 +0000
(13:12 +0200)
committer
Felix Fietkau
<nbd@nbd.name>
Fri, 5 May 2017 11:14:00 +0000
(13:14 +0200)
Significantly reduces time spent processing those targets and should
also silence some log clutter which could confuse buildbot
Signed-off-by: Felix Fietkau <nbd@nbd.name>
include/toplevel.mk
patch
|
blob
|
history
diff --git
a/include/toplevel.mk
b/include/toplevel.mk
index 4b63e8ab47a570c35d256ca011487f3d305b2799..d8ea6cff6085cb9762bf85023bb6c5b80d0f2cb2 100644
(file)
--- a/
include/toplevel.mk
+++ b/
include/toplevel.mk
@@
-184,6
+184,9
@@
prereq:: prepare-tmpinfo .config
check: .config FORCE
@+$(NO_TRACE_MAKE) -r -s $@ QUIET= V=s
+val.%: FORCE
+ @+$(NO_TRACE_MAKE) -r -s $@ QUIET= V=s
+
WARN_PARALLEL_ERROR = $(if $(BUILD_LOG),,$(and $(filter -j,$(MAKEFLAGS)),$(findstring s,$(OPENWRT_VERBOSE))))
ifeq ($(SDK),1)