MIPS: allow building with kcov coverage
authorAlexey Khoroshilov <khoroshilov@ispras.ru>
Wed, 6 Nov 2019 17:28:42 +0000 (20:28 +0300)
committerPaul Burton <paulburton@kernel.org>
Mon, 11 Nov 2019 18:46:53 +0000 (10:46 -0800)
Add ARCH_HAS_KCOV and HAVE_GCC_PLUGINS to MIPS config.
Disable instrumentation of vdso to avoid build failure.

Signed-off-by: Alexey Khoroshilov <khoroshilov@ispras.ru>
Signed-off-by: Paul Burton <paulburton@kernel.org>
Cc: Ralf Baechle <ralf@linux-mips.org>
Cc: James Hogan <jhogan@kernel.org>
Cc: linux-mips@vger.kernel.org
Cc: linux-kernel@vger.kernel.org
arch/mips/Kconfig
arch/mips/vdso/Makefile

index d689aa485d0c7e58b2c2800bcb8342c8ac713ec4..c86be02b6d89c12f235aff0ff80d20c5a1e44f47 100644 (file)
@@ -87,6 +87,8 @@ config MIPS
        select SYSCTL_EXCEPTION_TRACE
        select VIRT_TO_BUS
        select ARCH_HAS_PTE_SPECIAL if !(32BIT && CPU_HAS_RIXI)
+       select ARCH_HAS_KCOV
+       select HAVE_GCC_PLUGINS
 
 menu "Machine selection"
 
index 996a934ece7d66319a6048ceff22a8e31209e1cc..e05938997e696a99409215bc3ae7c44d7d8e58d4 100644 (file)
@@ -75,6 +75,7 @@ CFLAGS_REMOVE_vdso.o = -pg
 
 GCOV_PROFILE := n
 UBSAN_SANITIZE := n
+KCOV_INSTRUMENT := n
 
 #
 # Shared build commands.