packages/boxbackup: use new service functions
authorNicolas Thill <nico@openwrt.org>
Sun, 13 Nov 2011 22:16:19 +0000 (22:16 +0000)
committerNicolas Thill <nico@openwrt.org>
Sun, 13 Nov 2011 22:16:19 +0000 (22:16 +0000)
SVN-Revision: 29076

utils/boxbackup/Makefile
utils/boxbackup/files/bbstored.init

index 96a1303546f8083e3e5740550903af2edf533c9d..15c2cdb2f847198b3f9c6daf15724f82c9f54796 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=boxbackup
 PKG_VERSION:=0.11.1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
 PKG_SOURCE_URL:=http://www.boxbackup.org/trac/export/2998/box/packages
index c7ec58aa651c4cc04bb5334d2296fc3ef614a883..91e677ec67c631d4af33f835b7ebfee92aa68e86 100644 (file)
@@ -3,9 +3,6 @@
 
 START=90
 
-
-local NORUN=0
-
 start() {
        . /lib/functions/bbstored.sh
 
@@ -13,19 +10,13 @@ start() {
 
        if [ "$EXTERNAL_CONFIG" -eq 1 ]
        then
-               BXBK_CONFIG_FILE="$EXTERNAL_CONF_FILE"          
+               BXBK_CONFIG_FILE="$EXTERNAL_CONF_FILE"
        fi
-       [ "$NORUN" != "1" ] && /usr/sbin/bbstored "$BXBK_CONFIG_FILE"
+       service_start /usr/sbin/bbstored "$BXBK_CONFIG_FILE"
 }
 
 stop() {
        . /lib/functions/bbstored.sh
 
-       if [ -f "$PID_FILE" ]
-       then
-               kill $(cat "$PID_FILE")
-       else
-               killall bbstored
-       fi
+       service_stop /usr/sbin/bbstored
 }
-