compat-wireless: refresh patches
authorLuis R. Rodriguez <mcgrof@qca.qualcomm.com>
Tue, 13 Dec 2011 18:59:55 +0000 (10:59 -0800)
committerLuis R. Rodriguez <mcgrof@qca.qualcomm.com>
Tue, 13 Dec 2011 18:59:55 +0000 (10:59 -0800)
automatic refresh

Signed-off-by: Luis R. Rodriguez <mcgrof@qca.qualcomm.com>
patches/04-netns.patch
patches/08-rename-config-options.patch
patches/09-cfg80211-wext-padding.patch
patches/11-dev-pm-ops.patch
patches/12-mac80211-disable-tx-status.patch
patches/15-symbol-export-conflicts.patch
patches/22-multiqueue.patch
patches/25-multicast-list_head.patch
patches/36-workqueue.patch

index 16f01b568c25515677c47746690e5c37cb01e70c..c49098459dc8d6b3ae672ab7a3e1710c3bdd1565 100644 (file)
@@ -6,7 +6,7 @@ files...
 
 --- a/net/wireless/nl80211.c
 +++ b/net/wireless/nl80211.c
-@@ -5066,7 +5066,9 @@ static int nl80211_wiphy_netns(struct sk
+@@ -5094,7 +5094,9 @@ static int nl80211_wiphy_netns(struct sk
        if (!net_eq(wiphy_net(&rdev->wiphy), net))
                err = cfg80211_switch_netns(rdev, net);
  
index 93a0e60787453176a1d7a4a06b9efa74a8f19739..2f732766619b54c4c60a3a7a89b869bcc763d129 100644 (file)
@@ -107,13 +107,15 @@ CONFIG_BT_HIDP does not build with older kernel versions.
  hidp-objs := core.o sock.o
 --- a/drivers/net/wireless/wl12xx/Makefile
 +++ b/drivers/net/wireless/wl12xx/Makefile
-@@ -8,5 +8,5 @@ wl12xx_sdio_test-objs  = sdio_test.o
+@@ -7,7 +7,7 @@ wl12xx_sdio-objs       = sdio.o
  wl12xx-$(CONFIG_NL80211_TESTMODE)     += testmode.o
  obj-$(CONFIG_WL12XX)                  += wl12xx.o
  obj-$(CONFIG_WL12XX_SPI)              += wl12xx_spi.o
 -obj-$(CONFIG_WL12XX_SDIO)             += wl12xx_sdio.o
 +obj-$(CONFIG_COMPAT_WL12XX_SDIO)              += wl12xx_sdio.o
  
+ # small builtin driver bit
+ obj-$(CONFIG_WL12XX_PLATFORM_DATA)    += wl12xx_platform_data.o
 --- a/drivers/net/wireless/wl1251/Makefile
 +++ b/drivers/net/wireless/wl1251/Makefile
 @@ -5,4 +5,4 @@ wl1251_sdio-objs       += sdio.o
index 8340fb4f127415b26ccded88f5349cb6c39d09f4..24a21cb436074f2540f2f0d3c958c5abfc1bef08 100644 (file)
@@ -30,7 +30,7 @@ moved due to struct enlargements.
 
 --- a/include/net/cfg80211.h
 +++ b/include/net/cfg80211.h
-@@ -1977,6 +1977,9 @@ struct wiphy_wowlan_support {
+@@ -1978,6 +1978,9 @@ struct wiphy_wowlan_support {
  struct wiphy {
        /* assign these fields before you register the wiphy */
  
index a34f5def867a1d503b81337db1f91efa757b6bcf..0ac8ad2ef706f7df34dd5415bbd7d9c0b3a4b429 100644 (file)
@@ -84,7 +84,7 @@ calls on compat code with only slight modifications.
  /*
 --- a/drivers/net/wireless/ath/ath9k/pci.c
 +++ b/drivers/net/wireless/ath/ath9k/pci.c
-@@ -353,14 +353,10 @@ static int ath_pci_resume(struct device
+@@ -334,14 +334,10 @@ static int ath_pci_resume(struct device
        return 0;
  }
  
@@ -103,7 +103,7 @@ calls on compat code with only slight modifications.
  
  #define ATH9K_PM_OPS  (&ath9k_pm_ops)
  
-@@ -378,7 +374,12 @@ static struct pci_driver ath_pci_driver
+@@ -359,7 +355,12 @@ static struct pci_driver ath_pci_driver
        .id_table   = ath_pci_id_table,
        .probe      = ath_pci_probe,
        .remove     = ath_pci_remove,
@@ -148,7 +148,7 @@ calls on compat code with only slight modifications.
  static int __init
 --- a/drivers/net/wireless/iwlegacy/common.c
 +++ b/drivers/net/wireless/iwlegacy/common.c
-@@ -5079,15 +5079,17 @@ il_pci_resume(struct device *device)
+@@ -5078,15 +5078,17 @@ il_pci_resume(struct device *device)
  }
  EXPORT_SYMBOL(il_pci_resume);
  
index 6d186509413b96948683ebdfe3b803c58cb82208..019057d794e7f8d151049bc1be4d9432d2e3ad29 100644 (file)
@@ -6,7 +6,7 @@ So we need to just ifdef this part out.
 
 --- a/net/mac80211/tx.c
 +++ b/net/mac80211/tx.c
-@@ -1950,6 +1950,7 @@ netdev_tx_t ieee80211_subif_start_xmit(s
+@@ -1953,6 +1953,7 @@ netdev_tx_t ieee80211_subif_start_xmit(s
                goto fail;
        }
  
@@ -14,7 +14,7 @@ So we need to just ifdef this part out.
        if (unlikely(!multicast && skb->sk &&
                     skb_shinfo(skb)->tx_flags & SKBTX_WIFI_STATUS)) {
                struct sk_buff *orig_skb = skb;
-@@ -1988,6 +1989,7 @@ netdev_tx_t ieee80211_subif_start_xmit(s
+@@ -1991,6 +1992,7 @@ netdev_tx_t ieee80211_subif_start_xmit(s
                        skb = orig_skb;
                }
        }
index 0f78566fb7b86c38cb542a174ae2c58de849a173..e7af13d90bd49a405e7456d34cf81fcbe733d9d1 100644 (file)
@@ -3,7 +3,7 @@ To avoid conflicts with the other export we rename our.
 
 --- a/net/mac80211/rx.c
 +++ b/net/mac80211/rx.c
-@@ -3070,7 +3070,12 @@ void ieee80211_rx(struct ieee80211_hw *h
+@@ -3078,7 +3078,12 @@ void ieee80211_rx(struct ieee80211_hw *h
   drop:
        kfree_skb(skb);
  }
index 677209615e6069eb2b1acf5e78be803ef77da325..f221ef119fcdcf3b9e795aa2238f8554386728f9 100644 (file)
@@ -96,7 +96,7 @@ queue by using skb_set_queue_mapping(skb, 0) through ieee80211_tx_skb()
  
 --- a/net/mac80211/tx.c
 +++ b/net/mac80211/tx.c
-@@ -1470,6 +1470,10 @@ void ieee80211_xmit(struct ieee80211_sub
+@@ -1473,6 +1473,10 @@ void ieee80211_xmit(struct ieee80211_sub
                                return;
                        }
  
@@ -107,7 +107,7 @@ queue by using skb_set_queue_mapping(skb, 0) through ieee80211_tx_skb()
        ieee80211_set_qos_hdr(sdata, skb);
        ieee80211_tx(sdata, skb, false);
        rcu_read_unlock();
-@@ -2205,7 +2209,14 @@ void ieee80211_tx_pending(unsigned long
+@@ -2208,7 +2212,14 @@ void ieee80211_tx_pending(unsigned long
  
                if (skb_queue_empty(&local->pending[i]))
                        list_for_each_entry_rcu(sdata, &local->interfaces, list)
index adec4482860f10e963f9dc1a883c20a19ecaa81d..2dfcf5c02540ee012f62f612180c5e30cf93444a 100644 (file)
@@ -536,7 +536,7 @@ This also backport commit 2f787b0b76bf5de2eaa3ca3a29d89123ae03c856
  static void rtl8187_configure_filter(struct ieee80211_hw *dev,
 --- a/drivers/net/wireless/wl12xx/main.c
 +++ b/drivers/net/wireless/wl12xx/main.c
-@@ -2464,11 +2464,20 @@ struct wl1271_filter_params {
+@@ -2593,11 +2593,20 @@ struct wl1271_filter_params {
        u8 mc_list[ACX_MC_ADDRESS_GROUP_MAX][ETH_ALEN];
  };
  
@@ -557,7 +557,7 @@ This also backport commit 2f787b0b76bf5de2eaa3ca3a29d89123ae03c856
        struct wl1271 *wl = hw->priv;
  
        if (unlikely(wl->state == WL1271_STATE_OFF))
-@@ -2481,16 +2490,40 @@ static u64 wl1271_op_prepare_multicast(s
+@@ -2610,16 +2619,40 @@ static u64 wl1271_op_prepare_multicast(s
        }
  
        /* update multicast filtering parameters */
@@ -712,7 +712,7 @@ This also backport commit 2f787b0b76bf5de2eaa3ca3a29d89123ae03c856
  
 --- a/net/mac80211/ieee80211_i.h
 +++ b/net/mac80211/ieee80211_i.h
-@@ -796,7 +796,12 @@ struct ieee80211_local {
+@@ -797,7 +797,12 @@ struct ieee80211_local {
        struct work_struct recalc_smps;
  
        /* aggregated multicast list */
@@ -768,7 +768,7 @@ This also backport commit 2f787b0b76bf5de2eaa3ca3a29d89123ae03c856
        spin_unlock_bh(&local->filter_lock);
  
        /* be a bit nasty */
-@@ -606,9 +610,11 @@ struct ieee80211_hw *ieee80211_alloc_hw(
+@@ -607,9 +611,11 @@ struct ieee80211_hw *ieee80211_alloc_hw(
        wiphy->ht_capa_mod_mask = &mac80211_ht_capa_mod_mask;
  
        INIT_LIST_HEAD(&local->interfaces);
index ef6350ea51ecc8a10b17df2b165d5a77703eb872..04e183adbee1f7e848ffc1edc397b7a1adf1d0ad 100644 (file)
@@ -3,7 +3,7 @@ The rest is backported in include/linux/compat-2.6.37.h
 
 --- a/net/mac80211/main.c
 +++ b/net/mac80211/main.c
-@@ -1105,6 +1105,10 @@ static void __exit ieee80211_exit(void)
+@@ -1106,6 +1106,10 @@ static void __exit ieee80211_exit(void)
        rc80211_minstrel_ht_exit();
        rc80211_minstrel_exit();