--- a/net/wireless/nl80211.c
+++ b/net/wireless/nl80211.c
-@@ -5066,7 +5066,9 @@ static int nl80211_wiphy_netns(struct sk
+@@ -5094,7 +5094,9 @@ static int nl80211_wiphy_netns(struct sk
if (!net_eq(wiphy_net(&rdev->wiphy), net))
err = cfg80211_switch_netns(rdev, net);
hidp-objs := core.o sock.o
--- a/drivers/net/wireless/wl12xx/Makefile
+++ b/drivers/net/wireless/wl12xx/Makefile
-@@ -8,5 +8,5 @@ wl12xx_sdio_test-objs = sdio_test.o
+@@ -7,7 +7,7 @@ wl12xx_sdio-objs = sdio.o
wl12xx-$(CONFIG_NL80211_TESTMODE) += testmode.o
obj-$(CONFIG_WL12XX) += wl12xx.o
obj-$(CONFIG_WL12XX_SPI) += wl12xx_spi.o
-obj-$(CONFIG_WL12XX_SDIO) += wl12xx_sdio.o
+obj-$(CONFIG_COMPAT_WL12XX_SDIO) += wl12xx_sdio.o
+ # small builtin driver bit
+ obj-$(CONFIG_WL12XX_PLATFORM_DATA) += wl12xx_platform_data.o
--- a/drivers/net/wireless/wl1251/Makefile
+++ b/drivers/net/wireless/wl1251/Makefile
@@ -5,4 +5,4 @@ wl1251_sdio-objs += sdio.o
--- a/include/net/cfg80211.h
+++ b/include/net/cfg80211.h
-@@ -1977,6 +1977,9 @@ struct wiphy_wowlan_support {
+@@ -1978,6 +1978,9 @@ struct wiphy_wowlan_support {
struct wiphy {
/* assign these fields before you register the wiphy */
/*
--- a/drivers/net/wireless/ath/ath9k/pci.c
+++ b/drivers/net/wireless/ath/ath9k/pci.c
-@@ -353,14 +353,10 @@ static int ath_pci_resume(struct device
+@@ -334,14 +334,10 @@ static int ath_pci_resume(struct device
return 0;
}
#define ATH9K_PM_OPS (&ath9k_pm_ops)
-@@ -378,7 +374,12 @@ static struct pci_driver ath_pci_driver
+@@ -359,7 +355,12 @@ static struct pci_driver ath_pci_driver
.id_table = ath_pci_id_table,
.probe = ath_pci_probe,
.remove = ath_pci_remove,
static int __init
--- a/drivers/net/wireless/iwlegacy/common.c
+++ b/drivers/net/wireless/iwlegacy/common.c
-@@ -5079,15 +5079,17 @@ il_pci_resume(struct device *device)
+@@ -5078,15 +5078,17 @@ il_pci_resume(struct device *device)
}
EXPORT_SYMBOL(il_pci_resume);
--- a/net/mac80211/tx.c
+++ b/net/mac80211/tx.c
-@@ -1950,6 +1950,7 @@ netdev_tx_t ieee80211_subif_start_xmit(s
+@@ -1953,6 +1953,7 @@ netdev_tx_t ieee80211_subif_start_xmit(s
goto fail;
}
if (unlikely(!multicast && skb->sk &&
skb_shinfo(skb)->tx_flags & SKBTX_WIFI_STATUS)) {
struct sk_buff *orig_skb = skb;
-@@ -1988,6 +1989,7 @@ netdev_tx_t ieee80211_subif_start_xmit(s
+@@ -1991,6 +1992,7 @@ netdev_tx_t ieee80211_subif_start_xmit(s
skb = orig_skb;
}
}
--- a/net/mac80211/rx.c
+++ b/net/mac80211/rx.c
-@@ -3070,7 +3070,12 @@ void ieee80211_rx(struct ieee80211_hw *h
+@@ -3078,7 +3078,12 @@ void ieee80211_rx(struct ieee80211_hw *h
drop:
kfree_skb(skb);
}
--- a/net/mac80211/tx.c
+++ b/net/mac80211/tx.c
-@@ -1470,6 +1470,10 @@ void ieee80211_xmit(struct ieee80211_sub
+@@ -1473,6 +1473,10 @@ void ieee80211_xmit(struct ieee80211_sub
return;
}
ieee80211_set_qos_hdr(sdata, skb);
ieee80211_tx(sdata, skb, false);
rcu_read_unlock();
-@@ -2205,7 +2209,14 @@ void ieee80211_tx_pending(unsigned long
+@@ -2208,7 +2212,14 @@ void ieee80211_tx_pending(unsigned long
if (skb_queue_empty(&local->pending[i]))
list_for_each_entry_rcu(sdata, &local->interfaces, list)
static void rtl8187_configure_filter(struct ieee80211_hw *dev,
--- a/drivers/net/wireless/wl12xx/main.c
+++ b/drivers/net/wireless/wl12xx/main.c
-@@ -2464,11 +2464,20 @@ struct wl1271_filter_params {
+@@ -2593,11 +2593,20 @@ struct wl1271_filter_params {
u8 mc_list[ACX_MC_ADDRESS_GROUP_MAX][ETH_ALEN];
};
struct wl1271 *wl = hw->priv;
if (unlikely(wl->state == WL1271_STATE_OFF))
-@@ -2481,16 +2490,40 @@ static u64 wl1271_op_prepare_multicast(s
+@@ -2610,16 +2619,40 @@ static u64 wl1271_op_prepare_multicast(s
}
/* update multicast filtering parameters */
--- a/net/mac80211/ieee80211_i.h
+++ b/net/mac80211/ieee80211_i.h
-@@ -796,7 +796,12 @@ struct ieee80211_local {
+@@ -797,7 +797,12 @@ struct ieee80211_local {
struct work_struct recalc_smps;
/* aggregated multicast list */
spin_unlock_bh(&local->filter_lock);
/* be a bit nasty */
-@@ -606,9 +610,11 @@ struct ieee80211_hw *ieee80211_alloc_hw(
+@@ -607,9 +611,11 @@ struct ieee80211_hw *ieee80211_alloc_hw(
wiphy->ht_capa_mod_mask = &mac80211_ht_capa_mod_mask;
INIT_LIST_HEAD(&local->interfaces);
--- a/net/mac80211/main.c
+++ b/net/mac80211/main.c
-@@ -1105,6 +1105,10 @@ static void __exit ieee80211_exit(void)
+@@ -1106,6 +1106,10 @@ static void __exit ieee80211_exit(void)
rc80211_minstrel_ht_exit();
rc80211_minstrel_exit();