projects
/
openwrt
/
svn-archive
/
packages.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
3d5c56b
)
needs to get linked against libresolv.so when built inside an glibc/eglibc toolchain...
author
Mirko Vogt
<mirko@openwrt.org>
Sat, 25 Jun 2011 13:13:23 +0000
(13:13 +0000)
committer
Mirko Vogt
<mirko@openwrt.org>
Sat, 25 Jun 2011 13:13:23 +0000
(13:13 +0000)
SVN-Revision: 27281
utils/pciutils/Makefile
patch
|
blob
|
history
diff --git
a/utils/pciutils/Makefile
b/utils/pciutils/Makefile
index 7b47f126efa54c427fbe63715204a44cd2b44a1f..31f7a0289a392ed707bc692bca9efb171e38bf68 100644
(file)
--- a/
utils/pciutils/Makefile
+++ b/
utils/pciutils/Makefile
@@
-45,6
+45,10
@@
MAKE_FLAGS += \
HOST="$(GNU_TARGET_NAME)" \
ZLIB="yes" \
+ifneq ($(CONFIG_USE_EGLIBC)$(CONFIG_USE_GLIBC),)
+TARGET_LDFLAGS += -lresolv
+endif
+
define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/lib
$(CP) $(PKG_BUILD_DIR)/lib/libpci.a $(1)/usr/lib