projects
/
openwrt
/
staging
/
rmilecki.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
ce4d2fb
)
kernel: fix kmod-switch-rtl8366-smi dependency
author
John Crispin
<john@phrozen.org>
Thu, 10 May 2018 08:22:19 +0000
(10:22 +0200)
committer
John Crispin
<john@phrozen.org>
Thu, 10 May 2018 08:22:19 +0000
(10:22 +0200)
Signed-off-by: John Crispin <john@phrozen.org>
package/kernel/linux/modules/netdevices.mk
patch
|
blob
|
history
diff --git
a/package/kernel/linux/modules/netdevices.mk
b/package/kernel/linux/modules/netdevices.mk
index 23939b62bf50f489d709fbd4de24a13af2275776..f5e6d3d6f02cbca2fe7efb8f31e0c90c92a5b5be 100644
(file)
--- a/
package/kernel/linux/modules/netdevices.mk
+++ b/
package/kernel/linux/modules/netdevices.mk
@@
-209,7
+209,7
@@
$(eval $(call KernelPackage,switch-ip17xx))
define KernelPackage/switch-rtl8366-smi
SUBMENU:=$(NETWORK_DEVICES_MENU)
TITLE:=Realtek RTL8366 SMI switch interface support
- DEPENDS:=@GPIO_SUPPORT +kmod-swconfig
+ DEPENDS:=@GPIO_SUPPORT +kmod-swconfig
+CONFIG_OF:kmod-of-mdio
KCONFIG:=CONFIG_RTL8366_SMI
FILES:=$(LINUX_DIR)/drivers/net/phy/rtl8366_smi.ko
AUTOLOAD:=$(call AutoLoad,42,rtl8366_smi)