[package] add xkeyboard-config and install shared libX11 directory correctly
authorFlorian Fainelli <florian@openwrt.org>
Sat, 31 Jul 2010 22:33:35 +0000 (22:33 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sat, 31 Jul 2010 22:33:35 +0000 (22:33 +0000)
SVN-Revision: 22448

Xorg/xorg/data/xkeyboard-config/Makefile [new file with mode: 0644]
Xorg/xorg/lib/libX11/Makefile

diff --git a/Xorg/xorg/data/xkeyboard-config/Makefile b/Xorg/xorg/data/xkeyboard-config/Makefile
new file mode 100644 (file)
index 0000000..be355b7
--- /dev/null
@@ -0,0 +1,38 @@
+#
+# Copyright (C) 2008-2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=xkeyboard-config
+PKG_VERSION:=1.7
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=http://xlibs.freedesktop.org/xkbdesc/
+PKG_INSTALL:=1
+
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/xkeyboard-config
+  SECTION:=xorg-data
+  CATEGORY:=Xorg
+  SUBMENU:=data
+  TITLE:=xkeyboard-config
+  URL:=http://freedesktop.org/wiki/Software/XKeyboardConfig
+endef
+
+define Build/Configure
+       $(call Build/Configure/Default)
+endef
+define Package/xkeyboard-config/install
+  $(INSTALL_DIR) $(1)/usr/share/X11/xkb
+    $(CP) -v $(PKG_INSTALL_DIR)/usr/share/X11/xkb \
+      $(1)/usr/share/X11/
+endef
+
+$(eval $(call BuildPackage,xkeyboard-config))
index 2cba49e5dbaaf748f9555a7a68e657f28e36d8f5..9432953a4d3414c62eb6f8a027a70339b768f4e1 100644 (file)
@@ -74,9 +74,13 @@ endef
 
 define Package/libX11/install
        $(INSTALL_DIR) $(1)/usr/lib
+       $(INSTALL_DIR) $(1)/usr/share/X11
        $(CP) \
                $(PKG_INSTALL_DIR)/usr/lib/*.so* \
                $(1)/usr/lib/
+       $(CP)  \
+               $(PKG_INSTALL_DIR)/usr/share/X11/* \
+               $(1)/usr/share/X11
 endef
 
 $(eval $(call Feature,libX11))