update wput to 0.6.2 (#6410)
authorFlorian Fainelli <florian@openwrt.org>
Tue, 29 Dec 2009 18:59:53 +0000 (18:59 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Tue, 29 Dec 2009 18:59:53 +0000 (18:59 +0000)
SVN-Revision: 18964

net/wput/Makefile
net/wput/patches/100-socketlib.diff
net/wput/patches/102-wput.diff

index 59cc614b9d752a4632aabfd512d7e0f2be8ab02f..bb0c325b49a6c3ef10d84889b89cf9814e6019f6 100644 (file)
@@ -1,4 +1,4 @@
-# 
+#
 # Copyright (C) 2007-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=wput
-PKG_VERSION:=0.6.1
+PKG_VERSION:=0.6.2
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
 PKG_SOURCE_URL:=@SF/wput
-PKG_MD5SUM:=92b41efed4db8eb4f3443c23bf7ceecf
+PKG_MD5SUM:=a14c4c13d91d04d6119bdc977e8a8bdf
 
 include $(INCLUDE_DIR)/package.mk
 
index d365c10d99c277d6987246c4ca61f7c3e383f5cf..b5acafe420bb92a62b34a95ac28f70c25f7c45cd 100644 (file)
@@ -1,6 +1,6 @@
 --- a/src/socketlib.c
 +++ b/src/socketlib.c
-@@ -390,15 +390,13 @@ int socket_is_data_readable(int s, int t
+@@ -392,17 +392,15 @@ int socket_is_data_readable(int s, int t
  wput_socket * socket_timeout_connect(wput_socket * sock, struct sockaddr *remote_addr, size_t size, int timeout) {
    int c = 0;
    printout(vDEBUG, "initiating timeout connect (%d)\n", timeout);
@@ -12,7 +12,9 @@
 -  socket_set_blocking(sock->fd, 0);
 +  socket_set_blocking(sock->fd, 1);
    c = connect(sock->fd,remote_addr,size);
-   if(errno > 0 && errno != 115 && errno != 36) {
+   /* here was a check also for errno != 36 (FILENAMETOOLONG)
+    * maybe this was EINPROGRESS on another system? */
+   if(errno > 0 && errno != EINPROGRESS) {
 -      printout(vMORE, "[%s]", strerror(errno));
 +      printout(vMORE, "[%d:%s] ", errno, strerror(errno));
        return NULL;
index ec8ea27086fd0952b79277c0e99d2e2bf02fc834..19629b51df6ebfa84ba07fc65ca532b90517c8f5 100644 (file)
@@ -1,6 +1,6 @@
 --- a/src/wput.c
 +++ b/src/wput.c
-@@ -582,8 +582,8 @@ void commandlineoptions(int argc, char *
+@@ -621,8 +621,8 @@ void commandlineoptions(int argc, char *
                {"output-file", 1, 0, 'o'},     
                {"port-mode", 0, 0, 'p'},       
                {"proxy", 1, 0, 'Y'},           
                {"quiet", 0, 0, 'q'},           
                {"random-wait", 0, 0, 0},       
                {"remove-source-files", 0, 0, 'R'},
-@@ -601,7 +601,9 @@ void commandlineoptions(int argc, char *
-               {"version", 0, 0, 'V'},          //35
-               {"wait", 1, 0, 'w'},            
+@@ -642,7 +642,9 @@ void commandlineoptions(int argc, char *
                {"waitretry", 1, 0, 0},         
--              {0, 0, 0, 0}                    
-+              {"proxy_host", 1, 0, 0},
+               {"chmod", 1, 0, 'm'},
+               {"disable-tls", 0, 0, 0},
+-              {0, 0, 0, 0}                    //40
++              {"proxy_host", 1, 0, 0},         //40
 +              {"proxy_port", 1, 0, 0},
 +              {0, 0, 0, 0}
        };
      while (1)
      {
-@@ -656,6 +658,10 @@ void commandlineoptions(int argc, char *
-                 opt.basename = optarg;                              break;
-             case 37: //waitretry
+@@ -699,6 +701,10 @@ void commandlineoptions(int argc, char *
                  opt.retry_interval = atoi(optarg);                  break;
-+            case 38: //proxy_host
-+                              set_option("proxy_host", optarg);    break;
-+            case 39: //proxy_port
-+                              set_option("proxy_port", optarg);    break;
+           case 39: //disable-tls
+                   opt.tls = 2;                                    break;
++            case 40: //proxy_host
++                set_option("proxy_host", optarg);                   break;
++            case 41: //proxy_port
++                set_option("proxy_port", optarg);                   break;
              default:
                  fprintf(stderr, _("Option %s should not appear here :|\n"), long_options[option_index].name);
              }
-@@ -762,8 +768,11 @@ void commandlineoptions(int argc, char *
+@@ -806,8 +812,10 @@ void commandlineoptions(int argc, char *
  "  -l,  --limit-rate=RATE       limit upload rate to RATE\n"
  "  -nd, --no-directories        do not create any directories\n"
  "  -Y,  --proxy=http/socks/off  set proxy type or turn off\n"
@@ -43,7 +43,6 @@
 +"       --proxy_pass=PASS       set the proxy-password to PASS\n"
 +"       --proxy_port=PORT       set the proxy port to PORT\n"
 +"       --proxy_host=HOST       set the proxy host to HOST\n"
-+
  "\n"));
                        fprintf(stderr, _(
  "FTP-Options:\n"