fix a problem with the firewall script (multicast traffic could produce packet loss)
authorFelix Fietkau <nbd@openwrt.org>
Tue, 27 Mar 2007 16:45:10 +0000 (16:45 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Tue, 27 Mar 2007 16:45:10 +0000 (16:45 +0000)
SVN-Revision: 6726

openwrt/package/iptables/Makefile
openwrt/package/iptables/files/firewall.init

index 2e932b58a944ef1a08220a59287bd01097890781..27ffc0e6e94ccec65e0f77d4f046c7960ba2423e 100644 (file)
@@ -4,7 +4,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=iptables
 PKG_VERSION:=1.3.3
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 PKG_MD5SUM:=86d88455520cfdc56fd7ae27897a80a4
 
 PKG_SOURCE_URL:=http://www.netfilter.org/files \
index 7f161c9967e5108f460270fa1e7e2e786ea898d5..fd2dc8e8df8ed61d2aaa313705d6e50e2beeb9cc 100755 (executable)
@@ -96,7 +96,7 @@ iptables -A LAN_ACCEPT -j ACCEPT
   # uses the default -P DROP
 
 ### MASQ
-  iptables -t nat -A PREROUTING -m state --state NEW -j NEW
+  iptables -t nat -A PREROUTING -m state --state NEW -p tcp -j NEW
   iptables -t nat -A PREROUTING -j prerouting_rule
   iptables -t nat -A PREROUTING -i $WAN -j prerouting_wan