perf: fix version for APK
authorTil Kaiser <mail@tk154.de>
Tue, 12 Nov 2024 15:33:56 +0000 (16:33 +0100)
committerChristian Marangi <ansuelsmth@gmail.com>
Tue, 12 Nov 2024 16:55:16 +0000 (17:55 +0100)
Change the version schema of perf to be compatible with APK as
described in this commit: e8725a932e16eaf6ec51add8c084d959cbe32ff2.

Signed-off-by: Til Kaiser <mail@tk154.de>
Link: https://github.com/openwrt/openwrt/pull/16930
Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
package/devel/perf/Makefile

index 20be59516dad1226f40987b82edd7f8018c1a952..a2830420cc778c2a472d9b8fcddcf14bf51ffed6 100644 (file)
@@ -30,7 +30,7 @@ define Package/perf
   DEPENDS:= +libelf +libdw +PACKAGE_libunwind:libunwind +libpthread +librt +objdump @!IN_SDK @KERNEL_PERF_EVENTS \
            +PACKAGE_libbfd:libbfd +PACKAGE_libopcodes:libopcodes +libtraceevent
   TITLE:=Linux performance monitoring tool
-  VERSION:=$(LINUX_VERSION)-$(PKG_RELEASE)
+  VERSION:=$(LINUX_VERSION)-r$(PKG_RELEASE)
   URL:=http://www.kernel.org
 endef