kernel: bump 4.14 to 4.14.141
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Thu, 29 Aug 2019 09:09:29 +0000 (11:09 +0200)
committerKoen Vandeputte <koen.vandeputte@ncentric.com>
Fri, 30 Aug 2019 14:46:52 +0000 (16:46 +0200)
Refreshed all patches.

Compile-tested on: cns3xxx
Runtime-tested on: cns3xxx

Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
include/kernel-version.mk
target/linux/brcm2708/patches-4.14/950-0280-gpiolib-Don-t-prevent-IRQ-usage-of-output-GPIOs.patch
target/linux/brcm63xx/patches-4.14/143-gpio-fix-device-tree-gpio-hogs-on-dual-role-gpio-pin.patch

index 1cac92ece861c6c0d2c8d342f6071996cba139b2..96ce88fbcefcf33c85bf92315da197659b3574ba 100644 (file)
@@ -6,9 +6,9 @@ ifdef CONFIG_TESTING_KERNEL
   KERNEL_PATCHVER:=$(KERNEL_TESTING_PATCHVER)
 endif
 
-LINUX_VERSION-4.14 = .140
+LINUX_VERSION-4.14 = .141
 
-LINUX_KERNEL_HASH-4.14.140 = 795eed2515715ef29edd24f7a70912040cc206ec9a049c370cb305515f3fbdf2
+LINUX_KERNEL_HASH-4.14.141 = 0bb9f0812326ec4554de1bea02628840e03b6664b5abfd9d8510049e43203a17
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
 sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
index 830523e3bcc45cd4a1a7356edd1adb43b40c5c4e..dc854fac48736dfbdc362eb5727ac57b46c89286 100644 (file)
@@ -26,7 +26,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
  /* Device and char device-related information */
  static DEFINE_IDA(gpio_ida);
  static dev_t gpio_devt;
-@@ -2305,7 +2307,7 @@ static int _gpiod_direction_output_raw(s
+@@ -2307,7 +2309,7 @@ static int _gpiod_direction_output_raw(s
        int ret;
  
        /* GPIOs used for IRQs shall not be set as output */
@@ -35,7 +35,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
                gpiod_err(desc,
                          "%s: tried to set a GPIO tied to an IRQ as output\n",
                          __func__);
-@@ -2820,7 +2822,7 @@ int gpiochip_lock_as_irq(struct gpio_chi
+@@ -2822,7 +2824,7 @@ int gpiochip_lock_as_irq(struct gpio_chi
                        set_bit(FLAG_IS_OUT, &desc->flags);
        }
  
index 49156a0ada91cd47eddff5224e0e93e34c0ce466..f9af81f104d1ccd97b7a00f90c26e5e866cf32b8 100644 (file)
@@ -89,7 +89,7 @@ Signed-off-by: Jonas Gorski <jonas.gorski@gmail.com>
  
 --- a/drivers/gpio/gpiolib.c
 +++ b/drivers/gpio/gpiolib.c
-@@ -1940,7 +1940,8 @@ int gpiochip_add_pingroup_range(struct g
+@@ -1942,7 +1942,8 @@ int gpiochip_add_pingroup_range(struct g
  
        list_add_tail(&pin_range->node, &gdev->pin_ranges);
  
@@ -99,7 +99,7 @@ Signed-off-by: Jonas Gorski <jonas.gorski@gmail.com>
  }
  EXPORT_SYMBOL_GPL(gpiochip_add_pingroup_range);
  
-@@ -1992,7 +1993,7 @@ int gpiochip_add_pin_range(struct gpio_c
+@@ -1994,7 +1995,7 @@ int gpiochip_add_pin_range(struct gpio_c
  
        list_add_tail(&pin_range->node, &gdev->pin_ranges);