packages/restund: use new service functions
authorNicolas Thill <nico@openwrt.org>
Mon, 14 Nov 2011 02:38:45 +0000 (02:38 +0000)
committerNicolas Thill <nico@openwrt.org>
Mon, 14 Nov 2011 02:38:45 +0000 (02:38 +0000)
SVN-Revision: 29096

net/restund/Makefile
net/restund/files/restund.init

index 656adfa82a5e9e3318196ccd53932eb49dd98b6b..3d2b13f9ef2575128454f81425bb0856923def99 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=restund
 PKG_VERSION:=0.3.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.creytiv.com/pub/
index 2374a2795cb4d0e5f77d8d4a66bbce597349902f..d6360ff83afaf26efb3e21255ab7b068ed9a51c4 100644 (file)
@@ -5,13 +5,11 @@
 #
 
 START=60
-BIN=restund
-OPTIONS=
 
 start() {
-       start-stop-daemon -S -q -x $BIN -- $OPTIONS
+       service_start /usr/sbin/restund
 }
 
 stop() {
-       start-stop-daemon -K -q -x $BIN
+       service_stop /usr/sbin/restund
 }