ath79: streamline image-generation for OCEDO boards
authorDavid Bauer <mail@david-bauer.net>
Tue, 16 Jun 2020 21:26:55 +0000 (23:26 +0200)
committerDavid Bauer <mail@david-bauer.net>
Wed, 28 Oct 2020 10:58:20 +0000 (11:58 +0100)
Use the default sysupgrade generation procedure provided
by the target. The previously generated images had the rootfs not
aligned to an eraseblock.

Signed-off-by: David Bauer <mail@david-bauer.net>
target/linux/ath79/image/generic.mk

index 62fe78d73df49de57a746f4e1ba1a1beae4f21c4..c4707f7aa2804c11ba2caa921f7d4d371bc8b8e0 100644 (file)
@@ -1341,8 +1341,6 @@ define Device/ocedo_koala
   DEVICE_PACKAGES := kmod-ath10k-ct ath10k-firmware-qca988x-ct
   SUPPORTED_DEVICES += koala
   IMAGE_SIZE := 7424k
-  IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | \
-       append-metadata | check-size
 endef
 TARGET_DEVICES += ocedo_koala
 
@@ -1351,8 +1349,6 @@ define Device/ocedo_raccoon
   DEVICE_VENDOR := Ocedo
   DEVICE_MODEL := Raccoon
   IMAGE_SIZE := 7424k
-  IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | \
-       append-metadata | check-size
 endef
 TARGET_DEVICES += ocedo_raccoon
 
@@ -1362,8 +1358,6 @@ define Device/ocedo_ursus
   DEVICE_MODEL := Ursus
   DEVICE_PACKAGES := kmod-ath10k-ct ath10k-firmware-qca988x-ct
   IMAGE_SIZE := 7424k
-  IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | \
-       append-metadata | check-size
 endef
 TARGET_DEVICES += ocedo_ursus