projects
/
openwrt
/
staging
/
kaloz.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
bbad3f3
)
mxs: Include the right kernel image in the rootfs
author
Zoltan Herpai
<wigyori@uid0.hu>
Fri, 10 Apr 2015 21:34:21 +0000
(21:34 +0000)
committer
Zoltan Herpai
<wigyori@uid0.hu>
Fri, 10 Apr 2015 21:34:21 +0000
(21:34 +0000)
Signed-off-by: Harald Geyer <harald@ccbib.org>
Acked-by: Michael Heimpold <mhei@heimpold.de>
SVN-Revision: 45368
target/linux/mxs/image/Makefile
patch
|
blob
|
history
diff --git
a/target/linux/mxs/image/Makefile
b/target/linux/mxs/image/Makefile
index 55e88c25f3f344d5982f84a44e599f354f43526b..9830a7d616e8374bc6b2c902f047f2e975340196 100644
(file)
--- a/
target/linux/mxs/image/Makefile
+++ b/
target/linux/mxs/image/Makefile
@@
-22,10
+22,15
@@
endef
define Image/InstallKernel
- ifneq ($(CONFIG_TARGET_ROOTFS_INCLUDE_
KERNEL
),)
+ ifneq ($(CONFIG_TARGET_ROOTFS_INCLUDE_
ZIMAGE
),)
mkdir -p $(TARGET_DIR)/boot
$(CP) $(LINUX_DIR)/arch/arm/boot/zImage $(TARGET_DIR)/boot/
endif
+
+ ifneq ($(CONFIG_TARGET_ROOTFS_INCLUDE_UIMAGE),)
+ mkdir -p $(TARGET_DIR)/boot
+ cp $(KDIR)/uImage $(TARGET_DIR)/boot/
+ endif
ifneq ($(CONFIG_TARGET_ROOTFS_INCLUDE_DTB),)
mkdir -p $(TARGET_DIR)/boot