packages: add leptonica (used by upcoming tesseract package)
authorNicolas Thill <nico@openwrt.org>
Sun, 6 Nov 2011 18:15:27 +0000 (18:15 +0000)
committerNicolas Thill <nico@openwrt.org>
Sun, 6 Nov 2011 18:15:27 +0000 (18:15 +0000)
SVN-Revision: 28782

libs/leptonica/Makefile [new file with mode: 0644]

diff --git a/libs/leptonica/Makefile b/libs/leptonica/Makefile
new file mode 100644 (file)
index 0000000..fa217f6
--- /dev/null
@@ -0,0 +1,47 @@
+#
+# Copyright (C) 2011 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=leptonica
+PKG_VERSION:=1.68
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://leptonica.googlecode.com/files/
+PKG_MD5SUM:=5cd7092f9ff2ca7e3f3e73bfcd556403
+
+PKG_FIXUP:=libtool
+PKG_INSTALL:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/libleptonica
+  SECTION:=libs
+  CATEGORY:=Libraries
+  TITLE:=A library for efficient image processing and image analysis operations
+  URL:=http://leptonica.googlecode.com/
+  DEPENDS:=+giflib +libjpeg +libpng +libtiff +zlib
+endef
+
+TARGET_CFLAGS += $(FPIC)
+TARGET_LDFLAGS += -Wl,-rpath-link=$(STAGING_DIR)/usr/lib
+
+define Build/InstallDev
+       $(INSTALL_DIR) $(1)/usr/include
+       $(CP) $(PKG_INSTALL_DIR)/usr/include/leptonica $(1)/usr/include/
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/liblept.{a,so*} $(1)/usr/lib/
+endef
+
+define Package/libleptonica/install
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/liblept.so.* $(1)/usr/lib/
+endef
+
+$(eval $(call BuildPackage,libleptonica))
+