projects
/
openwrt
/
staging
/
lynxis.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
a117093
)
build: fix umask detection bashism
author
Thorsten Glaser
<tg@mirbsd.org>
Mon, 22 Oct 2018 17:28:50 +0000
(19:28 +0200)
committer
Jo-Philipp Wich
<jo@mein.io>
Wed, 30 Jan 2019 11:39:18 +0000
(12:39 +0100)
the leading 0 is optional and not emitted by some shells
Signed-off-by: Thorsten Glaser <tg@mirbsd.org>
include/prereq-build.mk
patch
|
blob
|
history
diff --git
a/include/prereq-build.mk
b/include/prereq-build.mk
index a416a2d2320990ef1888b621691246cf4eea4af1..f7da916f648c5c67f73938308fe2df26177204bb 100644
(file)
--- a/
include/prereq-build.mk
+++ b/
include/prereq-build.mk
@@
-24,7
+24,7
@@
$(eval $(call TestHostCommand,case-sensitive-fs, \
$(eval $(call TestHostCommand,proper-umask, \
Please build with umask 022 - other values produce broken packages, \
- umask | grep -xE 00[012][012]))
+ umask | grep -xE 0
?
0[012][012]))
$(eval $(call SetupHostCommand,gcc, \
Please install the GNU C Compiler (gcc) 4.8 or later, \