tools: e2fsprogs: pass --with-crond-dir=no instead of patching
authorRobert Marko <robimarko@gmail.com>
Wed, 25 Sep 2024 11:31:29 +0000 (13:31 +0200)
committerRobert Marko <robimarko@gmail.com>
Wed, 25 Sep 2024 17:53:13 +0000 (19:53 +0200)
Currently, e2fsprogs is being patched to avoid detecting host crond, but
instead of doing that we can simply pass --with-crond-dir=no as an
argument and drop the patch.

Link: https://github.com/openwrt/openwrt/pull/16500
Signed-off-by: Robert Marko <robimarko@gmail.com>
tools/e2fsprogs/Makefile
tools/e2fsprogs/patches/003-no-crond.patch [deleted file]

index 2c35adfa8f9b0784ab6629c3045e37cdddd45d53..8a8a2e181f3f7bcbde29b009a70ce2d314caea22 100644 (file)
@@ -30,7 +30,8 @@ HOST_CONFIGURE_ARGS += \
        --disable-tls \
        --disable-nls \
        --enable-threads=pth \
-       --disable-fuse2fs
+       --disable-fuse2fs \
+       --with-crond-dir=no
 
 define Host/Prepare
        $(call Host/Prepare/Default)
diff --git a/tools/e2fsprogs/patches/003-no-crond.patch b/tools/e2fsprogs/patches/003-no-crond.patch
deleted file mode 100644 (file)
index 67ddd4a..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/configure
-+++ b/configure
-@@ -15259,7 +15259,7 @@ then :
-               { printf "%s\n" "$as_me:${as_lineno-$LINENO}: result: ${crond_dir}" >&5
- printf "%s\n" "${crond_dir}" >&6; }
--              have_crond="yes"
-+              have_crond="no"; with_crond_dir=""
- else $as_nop