projects
/
openwrt
/
staging
/
kaloz.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
178721f
)
export switch-core.h to $(STAGING_DIR)
author
Felix Fietkau
<nbd@openwrt.org>
Sun, 6 Jan 2008 19:28:26 +0000
(19:28 +0000)
committer
Felix Fietkau
<nbd@openwrt.org>
Sun, 6 Jan 2008 19:28:26 +0000
(19:28 +0000)
SVN-Revision: 10138
package/switch/Makefile
patch
|
blob
|
history
diff --git
a/package/switch/Makefile
b/package/switch/Makefile
index 74e5778e230375a53e3931b2b7dc7e023152f711..43a4ee24b6de97f390379c8ad25d1edf918bfa08 100644
(file)
--- a/
package/switch/Makefile
+++ b/
package/switch/Makefile
@@
-51,7
+51,16
@@
define Build/Compile
EXTRA_CFLAGS="$(BUILDFLAGS)" \
modules
endef
-
+
+define Build/InstallDev
+ mkdir -p $(1)/usr/include
+ $(CP) ./src/switch-core.h $(1)/usr/include/
+endef
+
+define Build/UninstallDev
+ rm -f $(1)/usr/include/switch-core.h
+endef
+
define KernelPackage/switch/install
$(INSTALL_DIR) $(1)/lib/network/
$(INSTALL_BIN) ./files/switch.sh $(1)/lib/network/