update privoxy to 3.0.16, move to correct section, remove now useless patch (#6747)
authorFlorian Fainelli <florian@openwrt.org>
Sun, 28 Feb 2010 12:26:42 +0000 (12:26 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sun, 28 Feb 2010 12:26:42 +0000 (12:26 +0000)
SVN-Revision: 19898

net/privoxy/Makefile
net/privoxy/patches/102-remove_rej_files.patch [deleted file]

index 3e505bef3081cc8330c942134754d7542d176ac8..642ed59faa3a9f5143878c15d77cc96fc6cff7ab 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=privoxy
-PKG_VERSION:=3.0.12
+PKG_VERSION:=3.0.16
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-stable-src.tar.gz
 PKG_SOURCE_URL:=@SF/ijbswa
-PKG_MD5SUM:=c973e608d27b248ef567b47664308da1
+PKG_MD5SUM:=64d3ffcdf8307e04a375773bb4eb255e
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)-stable
 
@@ -22,6 +22,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/privoxy
   SECTION:=net
   CATEGORY:=Network
+  SUBMENU:=Proxy Servers
   DEPENDS:=+libpcre +libpthread
   TITLE:=web proxy with advanced filtering capabilities
   URL:=http://www.privoxy.org/
@@ -48,7 +49,6 @@ endef
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
                SPECIAL_CFLAGS="-pthread $(TARGET_LDFLAGS)"
-       mkdir -p $(PKG_INSTALL_DIR)
        $(MAKE) -C $(PKG_BUILD_DIR) \
                DESTDIR="$(PKG_INSTALL_DIR)" \
                install
diff --git a/net/privoxy/patches/102-remove_rej_files.patch b/net/privoxy/patches/102-remove_rej_files.patch
deleted file mode 100644 (file)
index 2f5cef3..0000000
+++ /dev/null
@@ -1,44 +0,0 @@
-diff -burN privoxy-3.0.12-stable/jcc.c.rej privoxy-3.0.12-stable.patched/jcc.c.rej
---- privoxy-3.0.12-stable/jcc.c.rej    2008-11-26 18:56:54.000000000 +0100
-+++ privoxy-3.0.12-stable.patched/jcc.c.rej    1970-01-01 01:00:00.000000000 +0100
-@@ -1,20 +0,0 @@
--***************
--*** 3110,3118 ****
--           }
--           continue;
--        }
---       log_error(LOG_LEVEL_INFO,
---          "Shouldn't get here but did.");
---       return;
--     }
--  
--     if (csp->content_length == 0)
----- 3120,3127 ----
--           }
--           continue;
--        }
--+       mark_server_socket_tainted(csp);
--+       return; /* huh? we should never get here */
--     }
--  
--     if (csp->content_length == 0)
-diff -burN privoxy-3.0.12-stable/parsers.c.rej privoxy-3.0.12-stable.patched/parsers.c.rej
---- privoxy-3.0.12-stable/parsers.c.rej        2008-09-15 19:52:19.000000000 +0200
-+++ privoxy-3.0.12-stable.patched/parsers.c.rej        1970-01-01 01:00:00.000000000 +0100
-@@ -1,16 +0,0 @@
--***************
--*** 986,991 ****
--  const add_header_func_ptr add_client_headers[] = {
--     client_host_adder,
--     client_cookie_adder,
--     client_xtra_adder,
--     /* Temporarily disabled:    client_accept_encoding_adder, */
--     connection_close_adder,
----- 983,989 ----
--  const add_header_func_ptr add_client_headers[] = {
--     client_host_adder,
--     client_cookie_adder,
--+    client_x_forwarded_adder,
--     client_xtra_adder,
--     /* Temporarily disabled:    client_accept_encoding_adder, */
--     connection_close_adder,