bcm4908: rename bootfs dummy file to the 1-openwrt
authorRafał Miłecki <rafal@milecki.pl>
Mon, 5 Apr 2021 22:03:31 +0000 (00:03 +0200)
committerRafał Miłecki <rafal@milecki.pl>
Thu, 8 Apr 2021 11:16:12 +0000 (13:16 +0200)
The purpose of that dummy file is to make CFE work properly with OpenWrt
bootfs. CFE for some reason ignores JFFS2 files with ino 0.

Rename it to 1-openwrt so:
1. It's consistent with bcm63xx
2. It's OpenWrt specific so sysupgrade can distinguish it from vendor
   images

Signed-off-by: Rafał Miłecki <rafal@milecki.pl>
(cherry picked from commit 880c8b44223c9cbce3dd14da78c33676c6f1a8a6)

target/linux/bcm4908/image/Makefile

index 59284d7b63ebb88203282bdf0ab173058d20852a..c7714ecf59fbd49b38e119f38ccc29f64f53566c 100644 (file)
@@ -15,7 +15,7 @@ define Build/bcm4908img
        rm -fr $@-bootfs
        mkdir -p $@-bootfs
        cp -r $(DEVICE_NAME)/* $@-bootfs/
-       touch $@-bootfs/1-dummy
+       touch $@-bootfs/1-openwrt
        cp $(DTS_DIR)/$(firstword $(DEVICE_DTS)).dtb $@-bootfs/94908.dtb
        cp $(KDIR)/bcm63xx-cfe/$(subst _,$(comma),$(DEVICE_NAME))/cferam.000 $@-bootfs/
        cp $(IMAGE_KERNEL) $@-bootfs/vmlinux.lz