create mode 100644 drivers/net/ethernet/atheros/alx/alx_main.c
create mode 100644 drivers/net/ethernet/atheros/alx/alx_sw.h
-diff --git a/MAINTAINERS b/MAINTAINERS
-index c9759ca..e4ef2c3 100644
--- a/MAINTAINERS
+++ b/MAINTAINERS
-@@ -1300,6 +1300,17 @@ W: http://atl1.sourceforge.net
+@@ -1301,6 +1301,17 @@ W: http://atl1.sourceforge.net
S: Maintained
F: drivers/net/ethernet/atheros/
ATM
M: Chas Williams <chas@cmf.nrl.navy.mil>
L: linux-atm-general@lists.sourceforge.net (moderated for non-subscribers)
-diff --git a/drivers/net/ethernet/atheros/Kconfig b/drivers/net/ethernet/atheros/Kconfig
-index 1ed886d..a1cfc98 100644
--- a/drivers/net/ethernet/atheros/Kconfig
+++ b/drivers/net/ethernet/atheros/Kconfig
@@ -56,15 +56,55 @@ config ATL1E
+ will be called alx.
+
endif # NET_VENDOR_ATHEROS
-diff --git a/drivers/net/ethernet/atheros/Makefile b/drivers/net/ethernet/atheros/Makefile
-index e7e76fb..5cf1c65 100644
--- a/drivers/net/ethernet/atheros/Makefile
+++ b/drivers/net/ethernet/atheros/Makefile
@@ -6,3 +6,4 @@ obj-$(CONFIG_ATL1) += atlx/
obj-$(CONFIG_ATL1E) += atl1e/
obj-$(CONFIG_ATL1C) += atl1c/
+obj-$(CONFIG_ALX) += alx/
-diff --git a/drivers/net/ethernet/atheros/alx/Makefile b/drivers/net/ethernet/atheros/alx/Makefile
-new file mode 100644
-index 0000000..9f607d3
--- /dev/null
+++ b/drivers/net/ethernet/atheros/alx/Makefile
@@ -0,0 +1,3 @@
+obj-$(CONFIG_ALX) += alx.o
+alx-objs := alx_main.o alx_ethtool.o alc_cb.o alc_hw.o alf_cb.o alf_hw.o
+ccflags-y += -D__CHECK_ENDIAN__
-diff --git a/drivers/net/ethernet/atheros/alx/alc_cb.c b/drivers/net/ethernet/atheros/alx/alc_cb.c
-new file mode 100644
-index 0000000..8c42c3b
--- /dev/null
+++ b/drivers/net/ethernet/atheros/alx/alc_cb.c
@@ -0,0 +1,912 @@
+ return 0;
+}
+
-diff --git a/drivers/net/ethernet/atheros/alx/alc_hw.c b/drivers/net/ethernet/atheros/alx/alc_hw.c
-new file mode 100644
-index 0000000..b0eb72c
--- /dev/null
+++ b/drivers/net/ethernet/atheros/alx/alc_hw.c
@@ -0,0 +1,1087 @@
+ return LX_DRV_PHY_UNKNOWN;
+}
+
-diff --git a/drivers/net/ethernet/atheros/alx/alc_hw.h b/drivers/net/ethernet/atheros/alx/alc_hw.h
-new file mode 100644
-index 0000000..492b4c1
--- /dev/null
+++ b/drivers/net/ethernet/atheros/alx/alc_hw.h
@@ -0,0 +1,1324 @@
+
+#endif/*L1C_HW_H_*/
+
-diff --git a/drivers/net/ethernet/atheros/alx/alf_cb.c b/drivers/net/ethernet/atheros/alx/alf_cb.c
-new file mode 100644
-index 0000000..d267760
--- /dev/null
+++ b/drivers/net/ethernet/atheros/alx/alf_cb.c
@@ -0,0 +1,1187 @@
+ return 0;
+}
+
-diff --git a/drivers/net/ethernet/atheros/alx/alf_hw.c b/drivers/net/ethernet/atheros/alx/alf_hw.c
-new file mode 100644
-index 0000000..3301457
--- /dev/null
+++ b/drivers/net/ethernet/atheros/alx/alf_hw.c
@@ -0,0 +1,918 @@
+ return LX_DRV_PHY_UNKNOWN;
+}
+
-diff --git a/drivers/net/ethernet/atheros/alx/alf_hw.h b/drivers/net/ethernet/atheros/alx/alf_hw.h
-new file mode 100644
-index 0000000..384af9a
--- /dev/null
+++ b/drivers/net/ethernet/atheros/alx/alf_hw.h
@@ -0,0 +1,2098 @@
+
+#endif/*L1F_HW_H_*/
+
-diff --git a/drivers/net/ethernet/atheros/alx/alx.h b/drivers/net/ethernet/atheros/alx/alx.h
-new file mode 100644
-index 0000000..6482bee
--- /dev/null
+++ b/drivers/net/ethernet/atheros/alx/alx.h
@@ -0,0 +1,670 @@
+#endif
+
+#endif /* _ALX_H_ */
-diff --git a/drivers/net/ethernet/atheros/alx/alx_ethtool.c b/drivers/net/ethernet/atheros/alx/alx_ethtool.c
-new file mode 100644
-index 0000000..c044133
--- /dev/null
+++ b/drivers/net/ethernet/atheros/alx/alx_ethtool.c
@@ -0,0 +1,519 @@
+{
+ SET_ETHTOOL_OPS(netdev, &alx_ethtool_ops);
+}
-diff --git a/drivers/net/ethernet/atheros/alx/alx_hwcom.h b/drivers/net/ethernet/atheros/alx/alx_hwcom.h
-new file mode 100644
-index 0000000..d3bd2f1
--- /dev/null
+++ b/drivers/net/ethernet/atheros/alx/alx_hwcom.h
@@ -0,0 +1,187 @@
+
+#endif/*_ALX_HWCOMMON_H_*/
+
-diff --git a/drivers/net/ethernet/atheros/alx/alx_main.c b/drivers/net/ethernet/atheros/alx/alx_main.c
-new file mode 100644
-index 0000000..a51c608
--- /dev/null
+++ b/drivers/net/ethernet/atheros/alx/alx_main.c
@@ -0,0 +1,3899 @@
+
+
+module_exit(alx_exit_module);
-diff --git a/drivers/net/ethernet/atheros/alx/alx_sw.h b/drivers/net/ethernet/atheros/alx/alx_sw.h
-new file mode 100644
-index 0000000..3daa392
--- /dev/null
+++ b/drivers/net/ethernet/atheros/alx/alx_sw.h
@@ -0,0 +1,493 @@
+
+#endif /* _ALX_SW_H_ */
+
---
-1.7.4.15.g7811d
-
}
-@@ -341,8 +341,10 @@ static int alx_set_mac_address(struct ne
+@@ -337,8 +341,10 @@ static int alx_set_mac_address(struct ne
if (netif_running(netdev))
return -EBUSY;
memcpy(netdev->dev_addr, addr->sa_data, netdev->addr_len);
memcpy(hw->mac_addr, addr->sa_data, netdev->addr_len);
-@@ -2483,7 +2487,7 @@ static void alx_free_all_rtx_descriptor(
+@@ -2483,7 +2489,7 @@ static void alx_free_all_rtx_descriptor(
ring_header->size = ring_header->used = 0;
}
static netdev_features_t alx_fix_features(struct net_device *netdev,
netdev_features_t features)
{
-@@ -2515,6 +2519,8 @@ static int alx_set_features(struct net_d
+@@ -2515,6 +2521,8 @@ static int alx_set_features(struct net_d
alx_vlan_mode(netdev, features);
return 0;
}
/*
* alx_change_mtu - Change the Maximum Transfer Unit
*/
-@@ -2538,7 +2544,17 @@ static int alx_change_mtu(struct net_dev
+@@ -2538,7 +2546,17 @@ static int alx_change_mtu(struct net_dev
adpt->hw.mtu = new_mtu;
adpt->rxbuf_size = new_mtu > ALX_DEF_RX_BUF_SIZE ?
ALIGN(max_frame, 8) : ALX_DEF_RX_BUF_SIZE;
alx_reinit_locked(adpt);
}
-@@ -3444,8 +3460,10 @@ static const struct net_device_ops alx_n
+@@ -3444,8 +3462,10 @@ static const struct net_device_ops alx_n
.ndo_change_mtu = alx_change_mtu,
.ndo_do_ioctl = alx_ioctl,
.ndo_tx_timeout = alx_tx_timeout,
#ifdef CONFIG_NET_POLL_CONTROLLER
.ndo_poll_controller = alx_poll_controller,
#endif
-@@ -3532,7 +3550,7 @@ static int __devinit alx_init(struct pci
+@@ -3532,7 +3552,7 @@ static int __devinit alx_init(struct pci
netdev->base_addr = (unsigned long)adpt->hw.hw_addr;
/* set cb member of netdev structure*/
alx_set_ethtool_ops(netdev);
netdev->watchdog_timeo = ALX_WATCHDOG_TIME;
strncpy(netdev->name, pci_name(pdev), sizeof(netdev->name) - 1);
-@@ -3580,6 +3598,7 @@ static int __devinit alx_init(struct pci
+@@ -3580,6 +3600,7 @@ static int __devinit alx_init(struct pci
adpt->max_rxques = min_t(int, ALX_MAX_RX_QUEUES, num_online_cpus());
adpt->max_txques = min_t(int, ALX_MAX_TX_QUEUES, num_online_cpus());
netdev->hw_features = NETIF_F_SG |
NETIF_F_HW_CSUM |
NETIF_F_HW_VLAN_RX;
-@@ -3591,6 +3610,19 @@ static int __devinit alx_init(struct pci
+@@ -3591,6 +3612,19 @@ static int __devinit alx_init(struct pci
}
netdev->features = netdev->hw_features |
NETIF_F_HW_VLAN_TX;
/* get mac addr and perm mac addr, set to register */
if (hw->cbs.get_mac_addr)
-@@ -3862,6 +3894,8 @@ static struct pci_error_handlers alx_err
+@@ -3862,6 +3896,8 @@ static struct pci_error_handlers alx_err
#ifdef CONFIG_PM_SLEEP
static SIMPLE_DEV_PM_OPS(alx_pm_ops, alx_suspend, alx_resume);
#define ALX_PM_OPS (&alx_pm_ops)
#else
#define ALX_PM_OPS NULL
#endif
-@@ -3874,7 +3908,12 @@ static struct pci_driver alx_driver = {
+@@ -3874,7 +3910,12 @@ static struct pci_driver alx_driver = {
.remove = __devexit_p(alx_remove),
.shutdown = alx_shutdown,
.err_handler = &alx_err_handler,