mediatek: change Routerich AX3000 ubi size
authorRomanov Danila <pervokur@gmail.com>
Mon, 21 Oct 2024 18:34:34 +0000 (21:34 +0300)
committerHauke Mehrtens <hauke@hauke-m.de>
Sat, 23 Nov 2024 14:42:24 +0000 (15:42 +0100)
All new routers are shipped with ubi size 112MB since early September.
Bootloader update required (ask vendor , see wiki)

These partitions weren't used:
firmware_backup
zrsave
config2

Signed-off-by: Romanov Danila <pervokur@gmail.com>
Link: https://github.com/openwrt/openwrt/pull/16686
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
target/linux/mediatek/dts/mt7981b-routerich-ax3000.dts
target/linux/mediatek/filogic/base-files/etc/board.d/05_compat-version
target/linux/mediatek/image/filogic.mk

index dfe44843b9df79f06a50f551ecfa30e68abf5c67..aa6a15ee1d120992e5d9a5b6e5d8c07add945c4f 100644 (file)
 
                        partition@580000 {
                                label = "ubi";
-                               reg = <0x580000 0x4000000>;
-                       };
-
-                       partition@4580000 {
-                               label = "firmware_backup";
-                               reg = <0x4580000 0x2000000>;
-                               read-only;
-                       };
-
-                       partition@6580000 {
-                               label = "zrsave";
-                               reg = <0x6580000 0x100000>;
-                               read-only;
-                       };
-
-                       partition@6680000 {
-                               label = "config2";
-                               reg = <0x6680000 0x100000>;
-                               read-only;
+                               reg = <0x580000 0x7000000>;
                        };
                };
        };
index d0cfd8f0a1232ef940fdff96a9e14c5a4a8d3f21..9b704b983cb7f0db3392042db1b2312b8b7a1a43 100644 (file)
@@ -8,6 +8,9 @@ case "$(board_name)" in
        bananapi,bpi-r3)
                ucidef_set_compat_version "1.2"
                ;;
+       routerich,ax3000)
+               ucidef_set_compat_version "1.1"
+               ;;
 esac
 
 board_config_flush
index 739fd543085c600d3b6d43e476f229a435e10d6d..cb5c102b1e2b64562371d2729cfa8b46d06279ca 100644 (file)
@@ -1173,6 +1173,11 @@ define Device/routerich_ax3000
   DEVICE_PACKAGES := kmod-mt7915e kmod-mt7981-firmware mt7981-wo-firmware kmod-usb3
   IMAGE/sysupgrade.bin := sysupgrade-tar | append-metadata
   SUPPORTED_DEVICES += mediatek,mt7981-spim-snand-rfb
+  DEVICE_COMPAT_VERSION := 1.1
+  DEVICE_COMPAT_MESSAGE := Partition layout has been changed. Bootloader MUST be \
+       upgraded to avoid data corruption and getting bricked. \
+       Please, contact your vendor and follow the guide: \
+       https://openwrt.org/toh/routerich/ax3000#web_ui_method
 endef
 TARGET_DEVICES += routerich_ax3000