projects
/
openwrt
/
staging
/
dangole.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
ed3860c
)
uboot-fritz4040: fix build with gcc7
author
Felix Fietkau
<nbd@nbd.name>
Mon, 12 Mar 2018 18:31:31 +0000
(19:31 +0100)
committer
Felix Fietkau
<nbd@nbd.name>
Mon, 12 Mar 2018 18:31:50 +0000
(19:31 +0100)
Signed-off-by: Felix Fietkau <nbd@nbd.name>
package/boot/uboot-fritz4040/Makefile
patch
|
blob
|
history
diff --git
a/package/boot/uboot-fritz4040/Makefile
b/package/boot/uboot-fritz4040/Makefile
index 4a36c55095e972f925c9a2c742bcece0283f6ac5..65d70e05022d19a4e8716f9b069d7bf8ed0780fa 100644
(file)
--- a/
package/boot/uboot-fritz4040/Makefile
+++ b/
package/boot/uboot-fritz4040/Makefile
@@
-37,6
+37,7
@@
define Build/Configure
$(HOSTCC) -o $(PKG_BUILD_DIR)/fritz/lzma2eva $(PKG_BUILD_DIR)/fritz/src/lzma2eva.c -lz
$(HOSTCC) -o $(PKG_BUILD_DIR)/fritz/tichksum $(PKG_BUILD_DIR)/fritz/src/tichksum.c
ln -sf $(STAGING_DIR_HOST)/bin/lzma $(PKG_BUILD_DIR)/fritz
+ ln -sf compiler-gcc5.h $(PKG_BUILD_DIR)/include/linux/compiler-gcc7.h
endef
define Build/Compile