tfa-layerscape: fix fiptool's build
authorPawel Dembicki <paweldembicki@gmail.com>
Tue, 24 Sep 2024 07:05:11 +0000 (09:05 +0200)
committerRobert Marko <robimarko@gmail.com>
Tue, 24 Sep 2024 10:29:06 +0000 (12:29 +0200)
Platform specified fiptool files was moved before lf-6.6.23-2.0.0 bump.
But PLAT_FIPTOOL_HELPER_MK still pointed to old location.
This cause problems with ls-ddr-phy build.

This patch fix PLAT_FIPTOOL_HELPER_MK path.

Fixes: 0ec659bd2b7e ("tfa-layerscape: Bump to lf-6.6.23-2.0.0")
Signed-off-by: Pawel Dembicki <paweldembicki@gmail.com>
Link: https://github.com/openwrt/openwrt/pull/16472
Signed-off-by: Robert Marko <robimarko@gmail.com>
package/boot/tfa-layerscape/Makefile

index c97dd997ffa6633f6d5d803d672a2111bef0146a..7304df55c713d814f882d541c4ff90b56152db1d 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=tfa-layerscape
 PKG_VERSION:=6.6.23.2.0.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=https://github.com/nxp-qoriq/atf
@@ -25,7 +25,7 @@ HOST_CFLAGS += -Wall -Werror -pedantic -std=c99
 define Host/Compile
        $(MAKE) -C \
                $(HOST_BUILD_DIR)/tools/fiptool \
-               PLAT_FIPTOOL_HELPER_MK="$(HOST_BUILD_DIR)/tools/nxp/plat_fiptool/plat_fiptool.mk" \
+               PLAT_FIPTOOL_HELPER_MK="$(HOST_BUILD_DIR)/tools/fiptool/plat_fiptool/nxp/plat_fiptool.mk" \
                CFLAGS="$(HOST_CFLAGS)" \
                LDFLAGS="$(HOST_LDFLAGS)" \
                HOSTCCFLAGS="$(HOST_CFLAGS)"