projects
/
openwrt
/
staging
/
zorun.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
9d7651b
)
include: don't use extended regex for deps checking
author
Nicolas Thill
<nico@openwrt.org>
Sat, 31 Jan 2015 08:15:46 +0000
(08:15 +0000)
committer
Nicolas Thill
<nico@openwrt.org>
Sat, 31 Jan 2015 08:15:46 +0000
(08:15 +0000)
Closes: #18851
Signed-off-by: Nicolas Thill <nico@openwrt.org>
SVN-Revision: 44224
include/package-ipkg.mk
patch
|
blob
|
history
diff --git
a/include/package-ipkg.mk
b/include/package-ipkg.mk
index 815aef093a2196906490c5c2eb0478550964c087..11edb9aeaa67c82ec13c7427b1fc30b291aa5204 100644
(file)
--- a/
include/package-ipkg.mk
+++ b/
include/package-ipkg.mk
@@
-66,7
+66,7
@@
ifneq ($(PKG_NAME),toolchain)
XARGS="$(XARGS)"; \
$(SCRIPT_DIR)/gen-dependencies.sh "$$(IDIR_$(1))"; \
) | while read FILE; do \
- grep -q
E
"^$$$$FILE$$$$" $(PKG_INFO_DIR)/$(1).provides || \
+ grep -q "^$$$$FILE$$$$" $(PKG_INFO_DIR)/$(1).provides || \
echo "$$$$FILE" >> $(PKG_INFO_DIR)/$(1).missing; \
done; \
if [ -f "$(PKG_INFO_DIR)/$(1).missing" ]; then \