kernel: bump 4.14 to 4.14.216
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Mon, 18 Jan 2021 14:34:52 +0000 (15:34 +0100)
committerKoen Vandeputte <koen.vandeputte@ncentric.com>
Thu, 21 Jan 2021 14:36:18 +0000 (15:36 +0100)
Refreshed all patches.

Compile-tested on: ar71xx, cns3xxx, imx6, x86_64
Runtime-tested on: ar71xx, cns3xxx, imx6

Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
include/kernel-version.mk
target/linux/generic/hack-4.14/220-gc_sections.patch
target/linux/generic/hack-4.14/221-module_exports.patch

index 6100a27d386810d4cc531adaf06d21e18f8dfe0f..f61362ef1f78758a5ef84f50630212eaa58ec756 100644 (file)
@@ -6,9 +6,9 @@ ifdef CONFIG_TESTING_KERNEL
   KERNEL_PATCHVER:=$(KERNEL_TESTING_PATCHVER)
 endif
 
-LINUX_VERSION-4.14 = .215
+LINUX_VERSION-4.14 = .216
 
-LINUX_KERNEL_HASH-4.14.215 = 9a844e290c61b39dd23df507ba1d9c2b2b4365e5993a978b19f1eb5610b926da
+LINUX_KERNEL_HASH-4.14.216 = b7864fef15ca9bdefe38cd19232538e3387f05c6ace17f44a0da07bd71edbba5
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
 sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
index 6a4475fc6e1e4c8b0420e57c1cf755da760a7ae8..fbf49aba90ae38be708a0f07f7ae2287b35b57c7 100644 (file)
@@ -238,7 +238,7 @@ Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
  
  /*
   * Data section helpers
-@@ -497,7 +498,7 @@
+@@ -500,7 +501,7 @@
  #define ENTRY_TEXT                                                    \
                ALIGN_FUNCTION();                                       \
                VMLINUX_SYMBOL(__entry_text_start) = .;                 \
@@ -247,7 +247,7 @@ Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
                VMLINUX_SYMBOL(__entry_text_end) = .;
  
  #define IRQENTRY_TEXT                                                 \
-@@ -604,7 +605,7 @@
+@@ -607,7 +608,7 @@
        . = ALIGN(sbss_align);                                          \
        .sbss : AT(ADDR(.sbss) - LOAD_OFFSET) {                         \
                *(.dynsbss)                                             \
index 003175c2236980973b7bc3981654f4b08aecaf3a..59a6528dd32838e5fd870496e906e05c110e5758 100644 (file)
@@ -56,7 +56,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        }                                                               \
                                                                        \
        /* __*init sections */                                          \
-@@ -796,6 +806,8 @@
+@@ -799,6 +809,8 @@
        EXIT_TEXT                                                       \
        EXIT_DATA                                                       \
        EXIT_CALL                                                       \