projects
/
openwrt
/
staging
/
lynxis.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
ccc728a
)
kernel/modules: kmod-chaoskey: Add missing dependency
author
Hauke Mehrtens
<hauke@hauke-m.de>
Mon, 18 Jun 2018 20:49:21 +0000
(22:49 +0200)
committer
Hauke Mehrtens
<hauke@hauke-m.de>
Mon, 18 Jun 2018 20:51:33 +0000
(22:51 +0200)
This new package was missing the dependency to kmod-random-core which
caused some build errors.
Fixes: 163ab9135a9 ("kernel/modules: add chaoskey module, hardware TRNG")
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
package/kernel/linux/modules/usb.mk
patch
|
blob
|
history
diff --git
a/package/kernel/linux/modules/usb.mk
b/package/kernel/linux/modules/usb.mk
index 2cf48e468f14f11122b771e36c7aae3078cdf6f9..8a4915712bf860cbdf27f59399df3789298c25ea 100644
(file)
--- a/
package/kernel/linux/modules/usb.mk
+++ b/
package/kernel/linux/modules/usb.mk
@@
-1642,6
+1642,7
@@
$(eval $(call KernelPackage,usb-net2280))
define KernelPackage/chaoskey
SUBMENU:=$(USB_MENU)
TITLE:=Chaoskey hardware RNG support
+ DEPENDS:=+kmod-random-core
KCONFIG:=CONFIG_USB_CHAOSKEY
FILES:=$(LINUX_DIR)/drivers/usb/misc/chaoskey.ko
AUTOLOAD:=$(call AutoProbe,chaoskey)