ramips: fix GB-PC1 and GB-PC2 device support
authorArınç ÜNAL <arinc.unal@arinc9.com>
Wed, 14 Sep 2022 18:31:40 +0000 (21:31 +0300)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 27 Nov 2022 15:27:37 +0000 (16:27 +0100)
Change switch port labels to ethblack & ethblue.
Change lan1 & lan2 LEDs to ethblack_act & ethblue_act and fix GPIO pins.
Add the external phy with ethyellow label on the GB-PC2 devicetree.
Do not claim rgmii2 as gpio, it's used for ethernet with rgmii2 function.
Enable ICPlus PHY driver for IP1001 which GB-PC2 has got.
Update interface name and change netdev function.
Enable lzma compression to make up for the increased size of the kernel.
Make spi flash bindings on par with mainline Linux to fix read errors.

Tested on GB-PC2 by Petr.

Tested-by: Petr Louda <petr.louda@outlook.cz>
Signed-off-by: Arınç ÜNAL <arinc.unal@arinc9.com>
(cherry picked from commit 4807bd6a00bcf44dd821047db76a2a799f403cd4)

target/linux/ramips/dts/mt7621_gnubee_gb-pc1.dts
target/linux/ramips/dts/mt7621_gnubee_gb-pc2.dts
target/linux/ramips/image/mt7621.mk
target/linux/ramips/mt7621/base-files/etc/board.d/01_leds
target/linux/ramips/mt7621/base-files/etc/board.d/02_network
target/linux/ramips/mt7621/config-5.4

index c218521c03cf5bcdfc56fdafd5137615fff52710..28601445e57003949ba4cca2d1324af5a2c0d7f4 100644 (file)
@@ -8,10 +8,10 @@
        model = "GB-PC1";
 
        aliases {
-               led-boot = &led_status;
-               led-failsafe = &led_status;
-               led-running = &led_status;
-               led-upgrade = &led_status;
+               led-boot = &led_system;
+               led-failsafe = &led_system;
+               led-running = &led_system;
+               led-upgrade = &led_system;
        };
 
        keys {
        leds {
                compatible = "gpio-leds";
 
-               system {
-                       label = "green:system";
-                       gpios = <&gpio 6 GPIO_ACTIVE_LOW>;
+               ethblack_act {
+                       label = "green:ethblack_act";
+                       gpios = <&gpio 3 GPIO_ACTIVE_LOW>;
                };
 
-               led_status: status {
-                       label = "green:status";
-                       gpios = <&gpio 8 GPIO_ACTIVE_LOW>;
+               ethblue_act {
+                       label = "green:ethblue_act";
+                       gpios = <&gpio 4 GPIO_ACTIVE_LOW>;
                };
 
-               lan1 {
-                       label = "green:lan1";
-                       gpios = <&gpio 24 GPIO_ACTIVE_LOW>;
+               power {
+                       label = "green:power";
+                       gpios = <&gpio 6 GPIO_ACTIVE_LOW>;
+                       linux,default-trigger = "default-on";
                };
 
-               lan2 {
-                       label = "green:lan2";
-                       gpios = <&gpio 25 GPIO_ACTIVE_LOW>;
+               led_system: system {
+                       label = "green:system";
+                       gpios = <&gpio 8 GPIO_ACTIVE_LOW>;
+                       linux,default-trigger = "disk-activity";
                };
        };
 };
@@ -59,9 +61,8 @@
        flash@0 {
                compatible = "jedec,spi-nor";
                reg = <0>;
-               spi-max-frequency = <80000000>;
+               spi-max-frequency = <50000000>;
                broken-flash-reset;
-               m25p,fast-read;
 
                partitions {
                        compatible = "fixed-partitions";
        ports {
                port@0 {
                        status = "okay";
-                       label = "lan1";
+                       label = "ethblack";
                };
 
                port@4 {
                        status = "okay";
-                       label = "lan2";
+                       label = "ethblue";
                };
        };
 };
 
 &state_default {
        gpio {
-               groups = "jtag", "rgmii2", "uart3", "wdt";
+               groups = "jtag", "uart3", "wdt";
                function = "gpio";
        };
 };
index 613524d1da5f48895e63cc8671e8d2c8eb86365d..c25ca886aecc9cca266c8a76ac1a0fb864c59b72 100644 (file)
@@ -8,10 +8,10 @@
        model = "GB-PC2";
 
        aliases {
-               led-boot = &led_status;
-               led-failsafe = &led_status;
-               led-running = &led_status;
-               led-upgrade = &led_status;
+               led-boot = &led_system;
+               led-failsafe = &led_system;
+               led-running = &led_system;
+               led-upgrade = &led_system;
        };
 
        keys {
        leds {
                compatible = "gpio-leds";
 
-               system {
-                       label = "green:system";
-                       gpios = <&gpio 6 GPIO_ACTIVE_LOW>;
-               };
-
-               led_status: status {
-                       label = "green:status";
-                       gpios = <&gpio 8 GPIO_ACTIVE_LOW>;
+               ethblack_act {
+                       label = "green:ethblack_act";
+                       gpios = <&gpio 3 GPIO_ACTIVE_LOW>;
                };
 
-               lan1 {
-                       label = "green:lan1";
-                       gpios = <&gpio 24 GPIO_ACTIVE_LOW>;
+               ethblue_act {
+                       label = "green:ethblue_act";
+                       gpios = <&gpio 4 GPIO_ACTIVE_LOW>;
                };
 
-               lan2 {
-                       label = "green:lan2";
-                       gpios = <&gpio 25 GPIO_ACTIVE_LOW>;
-               };
-
-               lan3-yellow {
-                       label = "yellow:lan3";
-                       gpios = <&gpio 13 GPIO_ACTIVE_LOW>;
+               power {
+                       label = "green:power";
+                       gpios = <&gpio 6 GPIO_ACTIVE_LOW>;
+                       linux,default-trigger = "default-on";
                };
 
-               lan3-green {
-                       label = "green:lan3";
-                       gpios = <&gpio 15 GPIO_ACTIVE_LOW>;
+               led_system: system {
+                       label = "green:system";
+                       gpios = <&gpio 8 GPIO_ACTIVE_LOW>;
+                       linux,default-trigger = "disk-activity";
                };
        };
 };
@@ -69,9 +61,8 @@
        flash@0 {
                compatible = "jedec,spi-nor";
                reg = <0>;
-               spi-max-frequency = <80000000>;
+               spi-max-frequency = <50000000>;
                broken-flash-reset;
-               m25p,fast-read;
 
                partitions {
                        compatible = "fixed-partitions";
        mtd-mac-address = <&factory 0xe000>;
 };
 
+&gmac1 {
+       status = "okay";
+       label = "ethyellow";
+       phy-handle = <&ethphy5>;
+
+       nvmem-cells = <&macaddr_factory_e000>;
+       nvmem-cell-names = "mac-address";
+};
+
+&mdio {
+       ethphy5: ethernet-phy@5 {
+               reg = <5>;
+               phy-mode = "rgmii-rxid";
+       };
+};
+
 &switch0 {
        ports {
                port@0 {
                        status = "okay";
-                       label = "lan1";
+                       label = "ethblack";
                };
 
                port@4 {
                        status = "okay";
-                       label = "lan2";
+                       label = "ethblue";
                };
        };
 };
 
 &state_default {
        gpio {
-               groups = "jtag", "rgmii2", "uart3", "wdt";
+               groups = "jtag", "uart3", "wdt";
                function = "gpio";
        };
 };
index c62087d8708f91cb76906d28d63b6638d11b36cb..36a03e872fd1e7e37b3aa889a46b7bc2b6cd64bc 100644 (file)
@@ -594,6 +594,7 @@ TARGET_DEVICES += glinet_gl-mt1300
 
 define Device/gnubee_gb-pc1
   $(Device/dsa-migration)
+  $(Device/uimage-lzma-loader)
   DEVICE_VENDOR := GnuBee
   DEVICE_MODEL := Personal Cloud One
   DEVICE_PACKAGES := kmod-ata-ahci kmod-usb3 kmod-sdhci-mt7620 -wpad-basic-wolfssl
@@ -603,6 +604,7 @@ TARGET_DEVICES += gnubee_gb-pc1
 
 define Device/gnubee_gb-pc2
   $(Device/dsa-migration)
+  $(Device/uimage-lzma-loader)
   DEVICE_VENDOR := GnuBee
   DEVICE_MODEL := Personal Cloud Two
   DEVICE_PACKAGES := kmod-ata-ahci kmod-usb3 kmod-sdhci-mt7620 -wpad-basic-wolfssl
index 95cf120f2de9ade6467315479aa0114919440d73..5234a773efe85c0ccf8c163220eaf3a934428d07 100755 (executable)
@@ -44,8 +44,8 @@ dlink,dir-882-r1)
        ;;
 gnubee,gb-pc1|\
 gnubee,gb-pc2)
-       ucidef_set_led_netdev "lan1" "lan1" "green:lan1" "lan1"
-       ucidef_set_led_netdev "lan2" "lan2" "green:lan2" "lan2"
+       ucidef_set_led_netdev "ethblack_act" "ethblack act" "green:ethblack_act" "ethblack" "tx rx"
+       ucidef_set_led_netdev "ethblue_act" "ethblue act" "green:ethblue_act" "ethblue" "tx rx"
        ;;
 linksys,e5600)
        ucidef_set_led_netdev "wan" "wan link" "blue:wan" "wan" "link"
index 4d081bed8cfd2a8dd89bb6ab3cd467cd801e0f49..9ebe652f83062c6c732157a6c47dce58e386be18 100755 (executable)
@@ -45,9 +45,11 @@ ramips_setup_interfaces()
        xiaomi,mi-router-4a-gigabit)
                ucidef_set_interfaces_lan_wan "lan1 lan2" "wan"
                ;;
-       gnubee,gb-pc1|\
+       gnubee,gb-pc1)
+               ucidef_set_interface_lan "ethblack ethblue"
+               ;;
        gnubee,gb-pc2)
-               ucidef_set_interface_lan "lan1 lan2"
+               ucidef_set_interface_lan "ethblack ethblue ethyellow"
                ;;
        linksys,re6500|\
        netgear,wac104)
index 642543f5885360cd39bef8613f074419635cf4cd..6ff91a9da741f26eefb9ad08607e5f060ca850bf 100644 (file)
@@ -107,6 +107,7 @@ CONFIG_HZ_PERIODIC=y
 CONFIG_I2C=y
 CONFIG_I2C_BOARDINFO=y
 CONFIG_I2C_MT7621=y
+CONFIG_ICPLUS_PHY=y
 CONFIG_INITRAMFS_SOURCE=""
 CONFIG_IRQCHIP=y
 CONFIG_IRQ_DOMAIN=y