openssh,pulseaudio: switch to new procd init script style
authorPeter Wagner <​tripolar@gmx.at>
Sun, 22 Sep 2013 17:41:58 +0000 (17:41 +0000)
committerPeter Wagner <​tripolar@gmx.at>
Sun, 22 Sep 2013 17:41:58 +0000 (17:41 +0000)
Signed-off-by: Peter Wagner <tripolar@gmx.at>
SVN-Revision: 38122

net/openssh/Makefile
net/openssh/files/sshd.init
sound/pulseaudio/Makefile
sound/pulseaudio/files/pulseaudio.init

index 3118655cf75661083a36ff48a395d6c076d3f4e7..a61220596ab3a81576ee5f4985d26b5d4b07807a 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=openssh
 PKG_VERSION:=6.2p2
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/ \
index ecc44c39e4437e4a1bce9308c344d3f3e8ddb7d9..879df12cdb9e44357d3770e1533879e5cee5b8d5 100644 (file)
@@ -4,9 +4,10 @@
 START=50
 STOP=50
 
-SERVICE_USE_PID=1
+USE_PROCD=1
+PROG=/usr/sbin/sshd
 
-start() {
+start_service() {
        for type in rsa dsa; do {
                # check for keys
                key=/etc/ssh/ssh_host_${type}_key
@@ -20,11 +21,10 @@ start() {
        user_exists sshd 22 || user_add sshd 22 22 sshd /var/empty
        group_exists sshd 22 || group_add sshd 22 
        mkdir -m 0700 -p /var/empty
-       service_start /usr/sbin/sshd
-}
 
-stop() {
-       service_stop /usr/sbin/sshd
+       procd_open_instance
+       procd_set_param command $PROG -D
+       procd_close_instance
 }
 
 shutdown() {
index 467b2b7e128f0c203950794bcf79bebce9247bbe..13996f57435c7293b619ffa07c81825577446c80 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=pulseaudio
 PKG_VERSION:=4.0
-PKG_RELEASE:=3
+PKG_RELEASE:=4
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=http://freedesktop.org/software/pulseaudio/releases/
index 6ad6af3c04f6472c45ddfd052f8d22743cb2cac6..4dbc5ecf5dab03ba491484294715b2db4e49a33e 100644 (file)
@@ -1,13 +1,13 @@
 #!/bin/sh /etc/rc.common
 # Copyright (C) 2011 OpenWrt.org
 
-START=65
-STOP=65
+START=99
+STOP=60
 
-SERVICE_USE_PID=1
-SERVICE_PID_FILE=/var/run/pulse/pid
+USE_PROCD=1
+PROG=/usr/bin/pulseaudio
 
-start() {
+start_service() {
        user_exists pulse 51 || user_add pulse 51
        group_exists pulse 51 || group_add pulse 51
        [ -d /var/run/pulse ] || {
@@ -20,12 +20,12 @@ start() {
                chmod 0750 /var/lib/pulse
                chown pulse:pulse /var/lib/pulse
        }
+
        chown root:pulse /dev/snd/* /dev/mixer /dev/dsp
        chmod 664 /dev/snd/* /dev/mixer /dev/dsp
 
-       service_start /usr/bin/pulseaudio --daemonize --system --disallow-exit --disallow-module-loading --disable-shm --exit-idle-time=-1
+       procd_open_instance
+       procd_set_param command $PROG --system --disallow-exit --disallow-module-loading --disable-shm --exit-idle-time=-1 --realtime=false
+       procd_close_instance
 }
 
-stop() {
-       service_stop /usr/bin/pulseaudio
-}