samba3: depend on cups if printing support is not disabled, fix build with SAMBA3_CON...
authorJo-Philipp Wich <jow@openwrt.org>
Wed, 30 Nov 2011 20:16:50 +0000 (20:16 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Wed, 30 Nov 2011 20:16:50 +0000 (20:16 +0000)
SVN-Revision: 29371

net/samba3/Makefile
net/samba3/patches/510-remove-printing.patch

index 877186ac4329bbc2cdaff489dcbfde7689de8d6a..613971a8b04027f682eeecc934d86859439317a6 100644 (file)
@@ -30,7 +30,7 @@ endef
 define Package/samba3
 $(call Package/samba3/Default)
   TITLE:=SMB server for file and printer sharing
-  DEPENDS:=+libpthread +libpopt $(ICONV_DEPENDS)
+  DEPENDS:=+libpthread +libpopt $(ICONV_DEPENDS) +!CONFIG_SAMBA3_CONFIG_NO_PRINTING:cups
 endef
 
 define Package/samba3-nmbd
index 680bec1e2da8aa9a1e2c8dba2f60d63375ff794d..c9260d1836706b3e3aa191513784b8fa8152b202 100644 (file)
@@ -14,7 +14,7 @@
  RPC_DFS_OBJ =  $(if $(OWRT_SMALLER),,rpc_server/srv_dfs.o rpc_server/srv_dfs_nt.o)
  
 -RPC_SPOOLSS_OBJ = $(if $(OWRT_SMALLER),,rpc_server/srv_spoolss.o rpc_server/srv_spoolss_nt.o)
-+RPC_SPOOLSS_OBJ = $(if $(OWRT_SMALLER)$(OWRT_NO_PRINTING),,rpc_server/srv_spoolss.o rpc_server/srv_spoolss_nt.o)
++RPC_SPOOLSS_OBJ = $(if $(OWRT_NO_PRINTING),,rpc_server/srv_spoolss.o rpc_server/srv_spoolss_nt.o)
  
  RPC_EVENTLOG_OBJ = $(if $(OWRT_SMALLER),,rpc_server/srv_eventlog.o rpc_server/srv_eventlog_nt.o rpc_server/srv_eventlog_lib.o)