bcm27xx: remove duplicated kmod-rp1-pio package
authorJohn Audia <therealgraysky@proton.me>
Sat, 4 Jan 2025 15:36:20 +0000 (16:36 +0100)
committerÁlvaro Fernández Rojas <noltari@gmail.com>
Sat, 4 Jan 2025 18:16:03 +0000 (19:16 +0100)
Commit f105d1a9a9739267fb25612d039c392a397775bd added a duplicated
kmod-rp1-pio package.
Also remove unneeded blank lines added by the same commit.

Fixes: f105d1a9a973 ("bcm27xx/bcm2712: Fix-up RP1 modules")
Signed-off-by: John Audia <therealgraysky@proton.me>
Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
target/linux/bcm27xx/modules/hwmon.mk
target/linux/bcm27xx/modules/other.mk

index db8ba30f875a4dc164ccdf937d1a6eafa2752454..320b11708f92216ae68a3e3be0022d96dd7d69b6 100644 (file)
@@ -32,5 +32,3 @@ define KernelPackage/hwmon-raspberrypi/description
 endef
 
 $(eval $(call KernelPackage,hwmon-raspberrypi))
-
-
index 099ce3ce14db885ffc3ca8f5bccf5dae5571ced1..7ec35c95f0b21c93a2d8989dcdbc937c716a43eb 100644 (file)
@@ -139,20 +139,3 @@ define KernelPackage/rp1-mailbox/description
 endef
 
 $(eval $(call KernelPackage,rp1-mailbox))
-
-
-define KernelPackage/rp1-pio
-  SUBMENU:=$(OTHER_MENU)
-  TITLE:=RP1 PIO driver
-  KCONFIG:=CONFIG_RP1_PIO
-  FILES:=$(LINUX_DIR)/drivers/misc/rp1-pio.ko
-  AUTOLOAD:=$(call AutoLoad,21,rp1-pio)
-  DEPENDS:=@TARGET_bcm27xx_bcm2712 +kmod-rp1
-endef
-
-define KernelPackage/rp1-pio/description
-  Driver for the RP1 PIO.
-endef
-
-$(eval $(call KernelPackage,rp1-pio))
-