target.mk: fix arm architecture level detection
authorLu jicong <jiconglu58@gmail.com>
Tue, 2 Jul 2024 13:01:49 +0000 (21:01 +0800)
committerChristian Marangi <ansuelsmth@gmail.com>
Wed, 3 Jul 2024 11:09:47 +0000 (13:09 +0200)
Now kernel configs of armv6k CPUs don't include CONFIG_CPU_V6.
So armv6k CPUs cannot be detected as arm_v6.
Fix this by adding detection for CONFIG_CPU_V6K.

Signed-off-by: Lu jicong <jiconglu58@gmail.com>
Link: https://github.com/openwrt/openwrt/pull/15855
Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
include/target.mk

index 386abf2ef1e22929235435f7f97cd984aecd5860..c9ff3cbb7cbdd60363b0b3e454c2e8643f3cf66a 100644 (file)
@@ -346,7 +346,15 @@ ifeq ($(DUMP),1)
     ifneq ($(CONFIG_CPU_MIPS32_R2),)
       FEATURES += mips16
     endif
-    FEATURES += $(foreach v,6 7,$(if $(CONFIG_CPU_V$(v)),arm_v$(v)))
+    ifneq ($(CONFIG_CPU_V6),)
+      FEATURES += arm_v6
+    endif
+    ifneq ($(CONFIG_CPU_V6K),)
+      FEATURES += arm_v6
+    endif
+    ifneq ($(CONFIG_CPU_V7),)
+      FEATURES += arm_v7
+    endif
 
     # remove duplicates
     FEATURES:=$(sort $(FEATURES))