6scripts: fix incorrect route command (#7203)
authorJo-Philipp Wich <jow@openwrt.org>
Fri, 23 Apr 2010 10:53:01 +0000 (10:53 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Fri, 23 Apr 2010 10:53:01 +0000 (10:53 +0000)
SVN-Revision: 21103

ipv6/6scripts/Makefile
ipv6/6scripts/files/6tunnel.init

index fb4d0df1e94ee8b8123628d162ad2b64abedb594..0ae95e6ffc3915dbfaf69dbf9aee85e14ec3074a 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=6scripts
 PKG_VERSION:=0.1
-PKG_RELEASE:=5
+PKG_RELEASE:=6
 
 include $(INCLUDE_DIR)/package.mk
 
index de01473c10a8190b6b4ebcab7ef33e442bcba7aa..0e955ee126d2ee99c370e897e70babe7953ef4cd 100644 (file)
@@ -24,7 +24,7 @@ start_service() {
        ip link set mtu $mtu dev $tnlifname
        ip tunnel change $tnlifname ttl $ttl
        ip addr add $localip6 dev $tnlifname
-       ip -6 route ::/0 dev $tnlifname
+       ip -6 route add ::/0 dev $tnlifname
        ip -6 route add 2000::/3 via $remoteip6
        ip -6 route add $delegatedip6 dev $LAN
 }