projects
/
openwrt
/
staging
/
thess.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
5137cdb
)
ar71xx: image: remove too big files in the CatFiles macro
author
Gabor Juhos
<juhosg@openwrt.org>
Sun, 22 Sep 2013 20:14:22 +0000
(20:14 +0000)
committer
Gabor Juhos
<juhosg@openwrt.org>
Sun, 22 Sep 2013 20:14:22 +0000
(20:14 +0000)
Also improve the warning message.
Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
SVN-Revision: 38125
target/linux/ar71xx/image/Makefile
patch
|
blob
|
history
diff --git
a/target/linux/ar71xx/image/Makefile
b/target/linux/ar71xx/image/Makefile
index bb6f6124f86f92743987246dd1500326223c98d4..65ddabec15fa041fb514f4d5d895b222c67ea14e 100644
(file)
--- a/
target/linux/ar71xx/image/Makefile
+++ b/
target/linux/ar71xx/image/Makefile
@@
-115,7
+115,8
@@
define CatFiles
esac; \
( dd if=$(1) bs=$$$${bs} conv=sync; cat $(3) ) > $(5); \
if [ `stat -c%s $(5)` -gt $(4) ]; then \
- echo "Warning: $(1) is too big" >&2; \
+ echo "Warning: $(5) is too big (> $(4) bytes)" >&2; \
+ rm -f $(5); \
fi; \
else if [ $(2) -gt 262144 -a `stat -c%s "$(1)"` -gt $(2) ]; then \
echo "Warning: $(1) is too big" >&2; \